Setup Insteon 4314U and link devices with RPI3

I am new to openHAB and cannot get the basic Insteon PLM setup and working with any device.

I have an openhabianpi setup on RPI3 with a 4314U modem connected. I added the PLM binding via the paper UI and it shows as installed (however the binding is not listed at Configuration > Bindings)

I set the port in the insteonplm.cfg file: port_0=/dev/ttyUSB0

I see log entries like below for the binding in the openhab.log:

2017-04-23 12:23:37.541 [INFO ] [nding.insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2017-04-23 12:23:37.647 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-insteonplm1': Error restarting bundles
2017-04-23 12:52:02.386 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2017-04-23 12:52:02.378 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2017-04-23 12:52:02.384 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: port_0 -> /dev/ttyUSB0
2017-04-23 12:52:02.386 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2017-04-23 12:52:02.406 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:     0
2017-04-23 12:52:02.437 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: service.pid -> org.openhab.insteonplm
2017-04-23 12:52:02.510 [INFO ] [onplm.internal.driver.SerialIOStream] - successfully opened port /dev/ttyUSB0
2017-04-23 12:52:02.843 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - modem database has 1 entries!
...
2017-04-23 15:52:02.456 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:     0

In order to test connecting to the modem, I thought I would link using the Insteon-Terminal. Setup and installed but when attempting to connect to the modem bu USB, I get this error:

no rxtxSerial in java.library.path thrown while loading gnu.io.RXTXCommDriver

I’m using this terminal command:

connectToMyUSB()

My init.py comtains:

def connectToMyUSB():
	"""connects to my modem on pre-defined usb port"""
	connectToSerial("/dev/ttyUSB0")

What could I be missing? Should I see the binding in the paper UI? What might be the issue with the terminal?

Do I need to link via the terminal before creating items or things for openHAB?

about the “no rxtxSerial” message: did you install/link the rxtx serial library as described in the insteonterminal readme file?

Looks like you are running OH2. What’s this ‘failed installing’ line about? That doesn’t look good.

Thanks for the reply, sorry for the slow response.

I did run the rxtx install. I re-ran to verify, sudo apt-get install ant default-jdk librxtx-java

Reading package lists... Done
Building dependency tree
Reading state information... Done
ant is already the newest version.
default-jdk is already the newest version.
librxtx-java is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 53 not upgraded.

Yes, I am running OH2 on openhabianpi. I tried uninstalling and re installing the InsteonPLM Binding, but still do not see it for configuration by OH2/PaperUI

I can’t help you with OH2, but about the insteonterminal error: did you also run the command to make the symbolic link as described in the insteonterminal instructions.

do you mean this command from the readme? cd /usr/lib/jvm/java-8/-oracle/jre/lib/amd64 ln -s /usr/lib/jni/librxtxSerial.so .

I tried, but do have the oracle vm. Does the rxtx still need to be linked?

I was able to link rxtx after installing oracle jvm. can connect to modem via USB, but modem.getId() and modem.getid() commands return getid got no reply! also, modem.getdb() hangs with no return. what should I try next?

Sorry, don’t know what to say. Are there any suspicious messages on the screen that would indicate what’s wrong?

Gary

Did you ever solve this?

I doubt they will answer. They last posted in October 2017.

image

Hi Bruce.

It was a stab in the dark. See what I did there. :crazy_face:

Bruce if you have time take a look at my post over at the link below. Maybe you can shed some light on things.

Compatibility with PowerLinc V2 USB 2414U w/ 2476S & 2476D?

1 Like

No. Gave up. Using a hub instead of the modem with the Pi. Works as expected.

1 Like

Gary

Thanks for the update.