Setup network share for windows <-> openhab

Hi community,

I followed the following guide ( to enable network share on my Raspberry Pi to be able to access files from my Win 10 PC. So far, all went right but I´m not able to execute the following command:

sudo chown -hR openhab:openhab /etc/openhab2 /opt/openhab2/conf

The error shown is: pi@raspberrypi:~ $ sudo chown -hR openhab:openhab /etc/openhab2 /opt/openhab2/config
chown: Zugriff auf ‘/opt/openhab2/config’ nicht möglich: Datei oder Verzeichnis nicht gefunden

(File not found).

I searched via the search function for the folders, checked permissions on the openhab2 folders found who are correctly set to owner=openhab.

Can you please advise, how I can check the permissions manually? I have tried to mount the RasPi on my Windows PC, but the network drive cannot be found.

Thanks for your help,


sudo chown -hR openhab:openhab /etc/openhab2 /opt/openhab2/conf

Ignore the /opt/openhab2/ path if you’re using a repository installation, the reason it’s mentioned is probally to cover both installations types.

Hi Alpoy,

thanks for your feedback! I tried all various options

sudo chown -hR openhab:openhab /etc/openhab2/conf
sudo chown -hR openhab:openhab /etc/openhab2
sudo chown -hR openhab:openhab /opt/openhab2/conf

without any success. Is there any alternative way to do this step? I believe this is the reason, why the network share doesn´t work yet, as permissions are not correctly set. Any chance to do this using the desktop view of rasbian?

Thanks a lot,

Solution: Realized that - for whatever reason - my logins weren´t accepted. I tried openhabian as login and the same as password and, tatatataaaaaa, it works!

Sometimes this really crazy…

1 Like

You saved my life! Same exact problem here! :+1:

thanks. it solved my problem too.