Setup of InsteonPLM - Can't get it to work :(

Sorry to rehash an old topic, but I have read the Insteon posts, and spent hours working through it all, and my bare-bones config still doesn’t work. I have an Insteon hub - 2014 version, I believe, since port 25105 seems to work.

  1. I just barely downloaded the OpenHab install - distribution-1.8.3-runtime.zip. I extracted it to an empty directory.

  2. I uncommented/made the following entries (with my credentials) in my openhab.cfg:

       insteonplm:port_0=/hub2/username:password@10.0.0.2:25105,poll_time=1000
       insteonplm:poll_interval=300000
    
  3. As you will see in the log, I have other dimmers too, but starting with one Lamplinc Dimmer #2457D2, I made this entry in an .items file:
    Dimmer couchLight “couch light” {insteonplm=“3A.6B.A0:F00.00.19#dimmer”}

  4. I made this .sitemap file:
    sitemap my label="Main Menu"
    Frame label=“Switches” {
    Switch item=couchlight mappings=[OFF=“All Off”]
    Slider item=couchlight
    }
    Frame label=“DP Demo” {
    Text label=“Group Demo” icon=“1stfloor” {
    Switch item=couchlight mappings=[OFF=“All Off”]
    }
    }

  5. Using either the built-in UI at http://localhost:8080/openhab.app?sitemap=my or the Android mobile app pointed to my PC, I click the toggle button to flip the light.

  6. Here is my log file:
    2016-11-20 21:32:00.519 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.3).
    2016-11-20 21:32:01.417 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
    2016-11-20 21:32:01.871 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
    2016-11-20 21:32:03.662 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
    2016-11-20 21:32:11.169 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'my.sitemap’
    2016-11-20 21:32:11.300 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'my.items’
    2016-11-20 21:32:12.356 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/openhab.app
    2016-11-20 21:32:14.797 [INFO ] [insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
    2016-11-20 21:32:14.813 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - poll interval set to 300000 per config file
    2016-11-20 21:32:14.813 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - dead device timeout set to 3000s
    2016-11-20 21:32:14.813 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: poll_interval -> 300000
    2016-11-20 21:32:14.813 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: port_0 -> /hub2/xxxx:yyyy@10.0.0.2:25105,poll_time=1000
    2016-11-20 21:32:14.813 [INFO ] [.service.AbstractActiveService] - InsteonPLM has been started
    2016-11-20 21:32:14.829 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: service.pid -> org.openhab.insteonplm
    2016-11-20 21:32:14.829 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
    2016-11-20 21:32:36.205 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - modem database has 8 entries!
    2016-11-20 21:32:36.205 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 3A.6B.A0 found in the modem database and the modem controls groups [0x00,0x09] and responds to groups [0x01].
    2016-11-20 21:32:36.205 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 3D.0B.CD found in the modem database, but is not configured as an item and the modem controls groups [0x00,0x07] and responds to groups [0x01].
    2016-11-20 21:32:36.205 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 3D.04.06 found in the modem database, but is not configured as an item and the modem controls groups [0x00,0x07] and responds to groups [0x01].
    2016-11-20 21:32:36.221 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 43.23.DF found in the modem database, but is not configured as an item and the modem controls groups [0x00,0x08] and responds to groups [0x01].
    2016-11-20 21:32:36.221 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 3A.6D.70 found in the modem database, but is not configured as an item and the modem controls groups [0x00] and responds to groups [0x01].
    2016-11-20 21:32:36.221 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 3D.17.50 found in the modem database, but is not configured as an item and the modem controls groups [0x00] and responds to groups [0x01].
    2016-11-20 21:32:36.221 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 3C.E8.A4 found in the modem database, but is not configured as an item and the modem controls groups [0x00,0x08] and responds to groups [0x01].
    2016-11-20 21:32:37.229 [INFO ] [.o.b.i.i.device.MessageHandler] - DimmerRequestReplyHandler: set device 3A.6B.A0 to level 100
    2016-11-20 21:32:50.771 [WARN ] [.o.u.w.i.render.SwitchRenderer] - Cannot determine item type of 'couchlight’
    org.openhab.core.items.ItemNotFoundException: Item ‘couchlight’ could not be found in the item registry
    at org.openhab.core.internal.items.ItemRegistryImpl.getItem(ItemRegistryImpl.java:80) ~[na:na]
    at org.openhab.ui.internal.items.ItemUIRegistryImpl.getItem(ItemUIRegistryImpl.java:554) ~[na:na]
    at org.openhab.ui.webapp.internal.render.SwitchRenderer.renderWidget(SwitchRenderer.java:57) ~[org.openhab.ui.webapp_1.8.3.jar:na]
    at org.openhab.ui.webapp.internal.render.PageRenderer.renderWidget(PageRenderer.java:158) [org.openhab.ui.webapp_1.8.3.jar:na]
    at org.openhab.ui.webapp.internal.render.PageRenderer.processChildren(PageRenderer.java:121) [org.openhab.ui.webapp_1.8.3.jar:na]
    at org.openhab.ui.webapp.internal.render.PageRenderer.processChildren(PageRenderer.java:138) [org.openhab.ui.webapp_1.8.3.jar:na]
    at org.openhab.ui.webapp.internal.render.PageRenderer.processPage(PageRenderer.java:86) [org.openhab.ui.webapp_1.8.3.jar:na]
    at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(WebAppServlet.java:127) [org.openhab.ui.webapp_1.8.3.jar:na]
    at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61) [org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841.jar:na]
    at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128) [org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841.jar:na]
    at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60) [org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841.jar:na]
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:848) [javax.servlet_3.0.0.v201112011016.jar:na]
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:598) [org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:486) [org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1065) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:413) [org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:999) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.Server.handle(Server.java:350) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630) [org.eclipse.jetty.http_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230) [org.eclipse.jetty.http_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:606) [org.eclipse.jetty.io_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46) [org.eclipse.jetty.io_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603) [org.eclipse.jetty.util_8.1.3.v20120522.jar:8.1.3.v20120522]
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538) [org.eclipse.jetty.util_8.1.3.v20120522.jar:8.1.3.v20120522]
    at java.lang.Thread.run(Thread.java:744) [na:1.8.0]
    2016-11-20 21:32:50.772 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Switch
    2016-11-20 21:32:50.777 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Switch
    2016-11-20 21:32:50.777 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Switch
    2016-11-20 21:32:50.777 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Switch
    2016-11-20 21:32:50.778 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Slider
    2016-11-20 21:32:50.778 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Slider
    2016-11-20 21:32:50.779 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Slider
    2016-11-20 21:32:50.779 [ERROR] [o.u.i.items.ItemUIRegistryImpl] - Cannot retrieve item couchlight for widget org.openhab.model.sitemap.Slider
    2016-11-20 21:32:54.153 [WARN ] [.w.internal.servlet.CmdServlet] - Received command ‘TOGGLE’ for item ‘couchlight’, but the item does not exist in the registry
    2016-11-20 21:32:56.311 [WARN ] [.w.internal.servlet.CmdServlet] - Received command ‘TOGGLE’ for item ‘couchlight’, but the item does not exist in the registry
    2016-11-20 21:33:02.401 [INFO ] [penhab.io.rest.RESTApplication] - Stopped REST API


Any ideas where I am going wrong? I have only one other clue to offer - I have not tried resolving this yet. Maybe I should. I downloaded the designer (for Windows 10) app, and it won’t run with some cryptic dll error that I don’t remember. After searching online, the talk seems to suggest that the Designer doesn’t work with a 64-bit JVM, and I have to downgrade to 32-bit. Not wanting to go through that pain, I haven’t tried it yet. So I coded my .items and .sitemap files by hand. So I suppose my 64-bit JVM could be getting in the way of my Insteon config, but since I get no Java errors, it doesn’t seem likely. Still, I thought I would tell you all, to give you the whole picture. Thanks for any help!

You’ve defined the item as:

Dimmer couchLight "couch light" {insteonplm="3A.6B.A0:F00.00.19#dimmer"}

and in the sitemap you have:

Switch item=couchlight mappings=[OFF="All Off"]

change it to

Switch item=couchLight mappings=[OFF="All Off"]

This will hopefully fix your issue.

Thank you Rob - sometimes a second set of eyes is the best solution! It does work now!

1 Like

Hello, I am running on Windows 8. I have followed (or at least think I have) all the instructions for adding the InsteonPLM binding to OpenHAB 2… I made the required changes in insteonplm.cfg. once this is complete, is there anything I should see in the PaperUI? In the logfile I am getting the error “modem database download unsuccessful, restarting!” … and this is repeating every 2 minutes. I did not alter the poll interval. I have been using the Insteon app for years with this Hub, and it is working correctly.

thanks, Terry

Are you using the correct COM port? Can you enable debugging and share the log files? I have no idea on how to enable debugging with OH2

I installed the binding from the OH2 PaperUI, and it created a insteonplm.cfg files for me. In the file I changed the following resources:

port_0=/hub2/insteonhub:myPassword@192.168.0.17:25105,poll_time=1000
poll_interval=300000 (changed to 400000 now)

My default.items file is as follows:

Switch myRouter “Network Router” { channel=“network:device:192_168_0_1:online” }
Switch Wallplug “My wallplug” { channel=“zwave:device:bb4d2b80:node30:switch_binary” }
Switch myMo “My weMo” { channel=“wemo:socket:Socket-1_0-221629K01002DB:state” }
Dimmer mantelLight “Fire Place Light” {insteonplm=“17.FF.BB:F00.00.01#dimmer”}

my default site map is:

sitemap default label=“Switches Sitemap”

Switch item=myRouter label="Main Router"
Switch item=Wallplug label="My Wallplug"
Switch item=myMo label="weMo One"
Slider item=mantelLight label="Fire Place Light"
Switch item=mantelLight mappings=[OFF="All Off"]

I am new, so I either do not have permission to upload a file or can not figure out how to do it. Here is the file contents on a clean run:

2017-01-13 15:42:44.383 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
2017-01-13 15:43:11.296 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2017-01-13 15:43:11.312 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2017-01-13 15:43:11.369 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2017-01-13 15:44:07.257 [INFO ] [nding.insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2017-01-13 15:45:25.801 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2017-01-13 15:45:25.801 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: port_0 -> /hub2/insteonhub:myPassword@192.168.0.17:25105,poll_time=1000
2017-01-13 15:45:25.801 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2017-01-13 15:45:25.801 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
2017-01-13 15:45:25.801 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: service.pid -> org.openhab.insteonplm
2017-01-13 15:47:25.817 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2017-01-13 15:49:25.822 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2017-01-13 15:51:23.898 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘wemo:socket:Socket-1_0-221629K01002DB’ to inbox.
2017-01-13 15:51:25.822 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2017-01-13 15:52:39.038 [ERROR] [ome.binding.wemo.handler.WemoHandler] - Failed to get actual state for device ‘wemo:socket:Socket-1_0-221629K01002DB’: Could not call WeMo
2017-01-13 15:53:25.829 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!

Let it sit for awhile and then this came up:
2017-01-13 16:38:05.797 [ERROR] [ding.insteonplm.internal.driver.Port] - got exception in write thread:
java.lang.StringIndexOutOfBoundsException: String index out of range: 199
at java.lang.String.substring(Unknown Source)[:1.8.0_111]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream.poll(HubIOStream.java:185)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream.write(HubIOStream.java:139)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream$HubOutputStream.flushBuffer(HubIOStream.java:308)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream$HubOutputStream.write(HubIOStream.java:302)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at java.io.OutputStream.write(Unknown Source)[:1.8.0_111]
at org.openhab.binding.insteonplm.internal.driver.IOStream.write(IOStream.java:67)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.Port$IOStreamWriter.run(Port.java:421)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at java.lang.Thread.run(Unknown Source)[:1.8.0_111]
2017-01-13 16:38:05.852 [ERROR] [ding.insteonplm.internal.driver.Port] - got exception in write thread:
java.lang.StringIndexOutOfBoundsException: String index out of range: 199
at java.lang.String.substring(Unknown Source)[:1.8.0_111]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream.poll(HubIOStream.java:185)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream.write(HubIOStream.java:139)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream$HubOutputStream.flushBuffer(HubIOStream.java:308)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.hub.HubIOStream$HubOutputStream.write(HubIOStream.java:302)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at java.io.OutputStream.write(Unknown Source)[:1.8.0_111]
at org.openhab.binding.insteonplm.internal.driver.IOStream.write(IOStream.java:67)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at org.openhab.binding.insteonplm.internal.driver.Port$IOStreamWriter.run(Port.java:421)[182:org.openhab.binding.insteonplm:1.9.0.201701130210]
at java.lang.Thread.run(Unknown Source)[:1.8.0_111]

how many devices do you have linked with the hub?

Right now I have 29 devices linked to the Hub (2242-222). I switched to a Linux Ubuntu 14 box now to see if I get any better results, but the download is still timing out. I am no longer getting the java error though. The database download seems to restart every two minutes, however from my readings I thought that the default was supposed to be five minutes. I changed the user name and password in the insteonplm.cfg file to verify I was getting a connection, and when I put in a wrong value it did fail to connect… so I am assuming it is connecting.

In another post I see mention of a database retry timeout resource, do you know where I could set that?

What happens if you set poll_time to 250 instead of 1000?

port_0=/hub2/insteonhub:myPassword@192.168.0.17:25105,poll_time=250
modem_db_retry_timeout=300000

Still no luck:

==> /var/log/openhab2/openhab.log <==
2017-01-14 22:17:52.800 [INFO ] [nding.insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2017-01-14 22:17:53.486 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - poll interval set to 300000 per config file
2017-01-14 22:17:53.508 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - setting modem db retry timeout to 300s
2017-01-14 22:17:53.508 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2017-01-14 22:17:53.514 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: poll_interval -> 300000
2017-01-14 22:17:53.514 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: modem_db_retry_timeout -> 300000
2017-01-14 22:17:53.515 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: port_0 -> /hub2/insteonhub:myPassword@192.168.0.17:25105,poll_time=250
2017-01-14 22:17:53.527 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2017-01-14 22:17:53.586 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: service.pid -> org.openhab.insteonplm
2017-01-14 22:17:53.586 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
2017-01-14 22:22:54.113 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2017-01-14 22:27:53.587 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
2017-01-14 22:27:54.114 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2017-01-14 22:32:54.115 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!

@Bernd_Pfrommer, any ideas?

I let this run all night and it did the same thing… restarted the database download every five minutes. I have a 2242-222… from what I have read I assume that is the hub with the PLM? I do not know what a hub vrs hub2 is… thanks for the help so far.

First, a bit of flame: hijacking an old thread is bad style. You should’ve opened a new one.

You have a hub 2242-222, which is a pre-2014, i.e. it should use the hub, not the hub2 syntax. You should connect to your hub like so

insteonplm:port_0=/hub/localhost:9761

Where you replace “localhost” with your hub’s hostname or ip address

I am new the world of forums. Sorry about hijacking an old thread, I did ask in another post if an issue was closed/ resolved if this was okay if you used the same post if I had the same problem, but did not get a response. I saw posts where people completely changed the topic, and realize that this confuses the issue. So I tried not to hijack an active post. I will not do it again.

In case anyone else is following, I did read the github entry https://github.com/openhab/openhab/wiki/Insteon-PLM-Binding for Installation and Configuration … but what threw me off was that my hub says the default port is 25105. That is why I selected the hub2 settings even though I should have selected the hub settings.

Changing the settings/ resource, 10 of the 29 Insteon items were downloaded from the database… thank you for the assistance.

Feel free to improve the documentation, all you need is a github account.

Sorry for being harsh, no malice intended.
@ranielsen, I updated the docs, but really this should be in the openhab_default.cfg file, which I will also update … if ever anyone uses it as a template, given that it’s in the 1.9 branch, not 1.8.3.

Terry, the 25105 port is also open on the “old” hub. It’s the official entry, but unfortunately only allows polling afaik. With the 2014 hub they closed the backdoor port, and only left 25105 open. In that sense the old hub is superior to the new one.

And my new hub 2014 just crapped out, maybe 2 years old. Dead as doorknob. No lights, probably the power supply, but that’s built into the unit :frowning:
But then I’m running off the PLM anyways. It just means that going forward I won’t be able to troubleshoot hub2 issues.