Setup openhabian with Raspberry pi


I wanted to install openhabian and I followed these steps here

I didn’t know how to make sure it has downloaded while working on my Raspberry. In the topic it says to wait 15-45 minutes to download, I waited about 2 hours. After 2 hours I opened “PUTTY” and tried to access. But after entering password etc it says like that:

2019-07-05_09:01:15_UTC [openHABian] Starting the openHABian initial setup.
2019-07-05_09:01:15_UTC [openHABian] Storing configuration… OK
2019-07-05_09:01:15_UTC [openHABian] Changing default username and password… O
2019-07-05_09:01:17_UTC [openHABian] Setting up Ethernet connection… OK
2019-07-05_09:01:17_UTC [openHABian] Ensuring network connectivity… OK
2019-07-05_09:01:17_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2019-07-05_09:02:19_UTC [openHABian] Updating repositories and upgrading install
ed packages… FAILED
2019-07-05_09:11:26_UTC [openHABian] Initial setup exiting with an error!

And I can not open the http://openhabianpi.local:8080/ page also.

Try to open the GUI with http://openhabianpi:8080 or direkt with

How does the screen look like, when you’re open your ssh-connection (Putty). Does it look like this?:

1 Like this is RPI’s IP right? They both don’t open anything, can’t even load the page Problem loading page

And the terminal doesn’t look like that, it directly shows the error.

That’s correct. The other way

is the is the "indirect way.

I don’t know the reason for the error. But the best would be, to make the setup-procedure once again from the beginning.
What kind of Pi you have ? Maybe is the SD-Card corrupt ? Is your RasPi realy connected to the Ethernet ?

1 Like

yes, I checked over terminal, it is connected to the internet. I have RPI 3 MODEL B. I changed the SD card will try again. How many hours I should wait at least to finish its downloading. Maybe I opened putty before it downloaded so it caused issues?

I tried this sudo /boot/
but again same error!

As I can see the second installation goes much further than the first one. The first one failed at “Updating the repositories…”. But as I understand you didn’t make a complete new installation from the beginning, but just running the installation-script again. I don’t know if this works.

When I installed my System (a while ago) I think it takes up to an hour.

You can try the following in the console:
Type in: sudo openhabian-config
If the openhabian Configuration Menue comes up you can do the next step and upgrade the system. Otherwise I only can say “One more time from the beginning”.
But maybe there are others in the forum to help you (@vzorglub, @Udo_Hartmann , @opus) .


I had trouble with http://openhabianpi:8080 so used http://ipaddress:8080 instead. If I remember correctly this worked.

did you mean this? But I still can’t reach

edit:I was able to update and upgrade it. Still can’t reach [http://openhabianpi:8080]
Do I need any extra thing to download from terminal to connect that?

Have tried to reach with ** []* ? from your Windows-Explorer (or Google-Chrome, or Firefox or whatelse) as @Adrian_Hills explained ?