Setup your own openhab-cloud (myopenhab) server/instance

myopenhab
myopenhaborg
openhab-cloud
Tags: #<Tag:0x00007f0152432b00> #<Tag:0x00007f0152432740> #<Tag:0x00007f0152432358>

(Kris K) #122

Hi Pedro

Not sure what you mean, OpenHab Cloud & OpenHab2 run locally on the same machine.

In any case, I cant remotely access the UI’s using the Local instance of OpenHab Cloud nor can I use the Android Apps to access OpenHab by configuring ‘REMOTE’ and pointing it to my https://domain, which in NGINX points towards Port 3000 of my Local OpenHab Cloud

:./

I’m at a loss and this is incredibly frustrating because theres no logs at all!


(Pedro Garcia) #123

Hi @dastrix80

Then you can use the local address in the OpenHab configuration, as in the screen snapshot you have sent.

First of all, have you tried connecting from the local network directly to the oh-cloud instance from your web browser? (i.e. http://192.168.0.3:3000)

If this does not work, then the cloud instance is not running / responding (or you have a firewall)

Best Regards,
Pedro


(Kris K) #124

Hi Pedro, yes it works and I can login. I also get cloud notifications however when I click the link ‘CLICK HERE TO ACCESS YOUR DASHBOARD’ it does nothing.Thanks


(Pedro Garcia) #125

Hi @dastrix80,

What does “does nothing” mean? Also, could you please try these to see if we can find some clues on what the issue is?

  • To what URL is the link “Click here to…” pointing to? Can you access the same URL directly on the OH instance?
  • Is the rest api responding through the OH-cloud instance? (i.e. ask for ‘/rest/sitemaps’ or ‘/rest/this-is-an-error’)
  • What is the contents of your “system” section in the “config.json” file? Host, port and protocol should match the URL you plan to reach your oh-cloud instance with.

Best Regards,
Pedro


(Kris K) #126

Hi Pedro

I made changes to config.json, the dashboard link now works. However I still cannot connect using the Android App. It pops up the list of sitemaps, but it wont display their contents

It works fine on a PC

Cheers


(Kris K) #127

Hi All

Does anyone use Habpanel with openhab cloud? If so, does your constantly keep asking for the username/password to login?

Thanks!


(Kris K) #128

THis is driving me mental and I dont know how to resolve it. Nginx doesnt appear to be the issue. Any thoughts?


(Glenn Goodman) #129

This should read:
sudo apt-get install nginx


(Glenn Goodman) #130

I think the step to create the directory is missing and should state:

sudo mkdir /var/www/openhab.dxxxd.net


(Glenn Goodman) #131

I just completed setting up openHAB Cloud using AWS EC2.

  • What’s the best node app.js to start when the server is rebooted?
  • I can’t get to frontail from openhab cloud. Is there something that needs to be configured to make that work?
  • Is there anyway to SSH into my openhab hub from outside my lan? Is that something that can be done via openHAB Cloud?
  • My understanding is the openHAB Cloud code is designed to support several openHAB hubs. Is there a way to configure openHAB Cloud so it only cares about a single openHAB hub?
  • Now that I have my own openHAB Cloud, how do I get Alexa Skill connected to it?

Thank you for these awesome instructions.


(Kris K) #132

Can anyone assist in setting up the Alexa Skil for a private instance of OH2 Cloud?


(Glenn Goodman) #133

I’m trying to figure out the same thing but I’m not sure it’s possible.


(Kris K) #134

Ive managed to set it up using this guide https://heathpaddock.com/2017/02/02/making-amazon-echo-alexa-sing-to-openhab2/#comment-10695

but I get linking unsuccessful when I open the Mobile App to link to my newly created skill.

The created skill is needed for using a private openhab cloud instance. I must be fairly close.


(Kris K) #135

Can you tell us more about how you got this working?

Do we select V2 or V3 for the payload? I get an unsuccessful account linking in the Alexa app when I try to link it.


(Kris K) #136

I got this working, the instructions are poorly written with respect to the Security Profile section

What you need to do in addition to the instructions is:

Set the Payload to be V2 under the Linking.
Ensure when you create the Amazon profile you do it under ‘LOGIN WITH AMAZON’ not under ‘Security Profiles’

Then it links


(Alpoy) #137

This has been bugging me for hours, I can’t get the app to work on my oh-clod/nginx instance!
The end result is always the “spinning circle of death” in the android app, and if I check my nginx access.log it seems it continuously tries to download the sitemap again and again.
(I’ve checked firewall logs, even tried disabling it. Also tried clearing any cache/default sitemap in the app).

Nginx access.log:

myexternalIP - myuserid [10/Oct/2018:10:51:22 +0200] "GET /api/v1/settings/notifications HTTP/1.1" 200 32 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:22 +0200] "GET /rest/bindings HTTP/1.1" 200 3138 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:22 +0200] "GET /rest/sitemaps HTTP/1.1" 200 416 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:22 +0200] "GET /rest/sitemaps/House/House HTTP/1.1" 400 270 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:23 +0200] "GET /rest/sitemaps/House/House HTTP/1.1" 400 270 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:23 +0200] "GET /rest/sitemaps/House/House HTTP/1.1" 400 270 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:23 +0200] "GET /rest/sitemaps/House/House HTTP/1.1" 400 270 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:23 +0200] "GET /rest/sitemaps/House/House HTTP/1.1" 400 270 "-" "okhttp/3.9.1"
myexternalIP - myuserid [10/Oct/2018:10:51:23 +0200] "GET /rest/sitemaps/House/House HTTP/1.1" 400 270 "-" "okhttp/3.9.1"
....the last lines of request repeats forever...

Any clues? :thinking:

Edit:
The server apparently sends a 400 (Bad Request) on the response, but can’t figure out why.
(No errors in nginx error.log)
Edit2:
If I manually login via web on my phone and try to retrieve the same url it works just fine, its only the app that won’t work


(shane kevin) #138

Wow thank you so much! However I think I ask the wrong question, sorry!
What I want is to be able to receive in app notification when using a custom openhab-cloud instance. (which will be possible when use offical website account but not possible for custom one?)
or are you saying the offical ohcloud website is using ifttt to achive in app notifications?
May I ask you when setup ifttt like you mentioned above, do you receive the in app notification from your custom oh-cloud instance?
sorry for those noob questions.


(Pedro Garcia) #139

I have tested in-app notification (using Google Cloud Messaging configuration on the custom oh-cloud instance), but I have not used it for anything else than testing sending a message from the oh-cloud web interface. Not sure I can help here…

OH-cloud is able to send notifications directly through the google cloud messaging engine. You need to configure a project in google cloud and set-up the openauth to make it work anyway. No need for IFTTT.

I have only used IFTTT to send events to my custom OH-cloud instance, so I have not tried it to send notifications to the mobile. It might work, anyway.


(Anjana) #140

How did you manage to translate IFTTT request URI to the openhab REST api endpoint? IFTTT appends “ifttt/v1/status” to the end of the rest end point and this cause a 401 response from my private openhab-cloud.


(Pedro Garcia) #141

I am not using IFTTT anymore (too unreliable for geofencing, which was what I mostly wanted it for), but here some snapshots of the API config I was using, in case it is useful to somebody. It is probably not the best in the world, and can be surely improved

My IFTTT API configuration for custom OH Cloud instance: