Several Z-Wave Plus Devices show as 'Unknown Device'


Just starting out with home automation/OH2. OH2 installation along with Z-wave controller stick is up & running. I purchased the following Zwave+ devices to get started:

  • Ecolink - Door & Window Sensor
  • Ecolink - Garage Door Tilt Sensor
  • Ecolink - Home Motion Sensor
  • Innovelli - Zwave Plus NZW37 Dual Z-Wave Plug

After putting the z-wave controller & the z-wave device in inclusion mode, I was able to get them added to the OH2; however, every single device that was added show up as “unknown device” (even after several hours was given for OH2 to retrieve device info.). All the added devices also show up as being “online”. My first question is are any of the above-mentioned device supported under OH2? Using HABmin, I’ve tried excluding/deleting these devices, but I’m unable to do so. Though I get a message stating that task was succesfully completed (ie: device exclusion/deletion), all those device still show up as Things under HABmin & PaperUI. I’ve restarted OH2 as well as the host running OH2 to no avail.

Sorry to vent out, but it has been a bit frustration as I have not been able to get a single device working under OH2. Of course, my lack of OH2 knowledge is probably the primary reason why I haven’t been able to get anything working. Any guidance/help would be much appreciated!


The first three devices are battery operated (I guess), you need to wake them up (normally done through a button by clicking one or several times rapidly). Then they will send information frames to the controller to get them initialized.
The NZW37 was added a couple of days ago, you need a recent zwave snapshot binding to get them to work.

To verify if your devices are supported look them up in the database:

1 Like


Take a look here!.
AFAIK, if the devices are not in the database, then, yes they are unknown to the Z-Wave binding, but I know @chris can tell you a lot more about this!

Best regards,

Thank you for the kind reply. I’m just thinking if none of these devices are supported under OH2.

It’s not that they are not supported, no one “declared” them! Am I right @chris?
Best regards,

1 Like

Just look them up and you will know.
And if they are not in the db you can easily add them.

1 Like

Thanks again!

If the device is not in the “supported device list”, does that mean they will not function or maybe function at a low compatibility (ie: features) level?

Also, if these devices are not in the database, does adding them to the database then allow for these devices to function under OH2?

I was under the impression that Z-wave certified devices (via their strict certification standards), all have standard interfaces that allow OH2 or any home automation controller to control z-wave certified devices without any concern of compatibilty…


Just checked out the device database. It turns out that following device is supported:
(Z-wave Plus Easy Install with PET Immunity Motion Detector with PET Immunity, White (PIRZWAVE2.5-ECO)" is actually supported (ie: its in the database). However, this supported device shows up as “unknown device

If a battery device: wake it up! If not or recently added to the db: install a recent zwave snapshot binding

As @sihui said, what binding version are you using?

Current z-wave binding: binding-zwave - 2.0.0

How do you install more updated/snapshot of the binding?


If you are on the stable runtime release, updating to the snapshot zwave binding possibly won’t work.
Your best bet is updating to the 2.1 stable release from today:

While I don’t know if we have the same hardware versions… but there may be a regression in 2.1. I have a couple Ecolink door/window sensors and one tilt sensor.

All of these worked perfect on 2.0. When updating to 2.1 it was a bit more of a challenge to get the devices to be recognized. After some manual waking (replace covers) and zwave searching, openhab does see the channels.

Now here is the interesting part… the thing found in paper ui finds a sensor_door channel, but the device is reporting in on the sensor_binary channel (observed via zwave debug logging). Openhab 2.0 finds the sensor_binary channel in paper ui, openhab 2.1 finds the (non functional) sensor_door channel in paper ui.

I can’t get any of the devices to update item status in 2.1 after working perfectly fine in the 2.0 stable branch.

What do you mean by this? Are you getting confused about command classes and channels? The device will report with a command class, and the binding converts this to a channel. The command class might be sensor_binary, or alarm/notification depending on the device, but the channel will be sensor_door.

Is it possible for a device to work if it wasn’t in the database in 2.0? In the device database I see this device was added/updated in February (after 2.0 stable). This might be the cause of the change from the sensor_binary to sensor_door channels.

In any case, once the channel is found and I link to an item, the updates from the binding are never making it to the item. All other zwave items work fine, only my two nodes with this specific hardware is impacted. The zwave debugging shows the 0 and 255 commands coming in from the device.

Any suggestions on how I can troubleshoot why these commands aren’t making it back to the item?

No - for now, it needs to be in the database. I plan to change this in future, but this was a limitation in ESH when the binding was written - the only way to define a thing was to use the ESH XML files, so this is how the binding works.

Node 255 is the controller, so it’s perfectly normal. If something says node 0, then there might be a problem with something.[quote=“Brady, post:15, topic:30694”]
Any suggestions on how I can troubleshoot why these commands aren’t making it back to the item?

I would suggest to get a debug log and see what this shows - it’s normally the best/only way to debug low level issues.

Sorry, I didn’t accurately explain. I was seeing the SENSOR_BINARY command class deliver VALUES 0 and 255 (OFF and ON).

I did just figure out why it wasn’t working for me… In 2.0 I did have these devices working… as switches that I was just displaying the values of. In 2.1, I just changed my item definitions to Contact and it is now working. Silly mistake that cost me a lot of head scratching last night.

Chris, thanks for your feedback (and as always your excellent work on the zwave binding!!)

As for the original poster… I was having the same issues on 2 out of the 4 devices. Give it time and it should find the two ecolink door & tilt sensors. They are in the device database. I went to bed last night and this morning the device had been identified.

I’m all good now and will stop contributing to any confusion :slight_smile:

1 Like