Shelly 1PM Mini Gen3

Dear Shelly dev’s,

Recently I bought a couple of Shelly 1PM Mini’s, I received the Gen3 model. They’re not playing nice with the 4.1 Shelly binding release. I tried them with the most recent OH 4.2 snapshot build and as well with the 4.2 Shelly binding snapshot build. In both cases I’ve got alot of communication errors.
So, am I correct in asuming these Gen3 models aren’t supported yet?
And is there maybe a workaround to get them playing nice with the 4.1 build, or do I need to be just a littlepatient? I hope someone can help me out.

Best regards,

I’m using my Shelly PM Mini Gen3 with MQTT unitl they are working fine with the newest shelly binding version.
This should also work with the 1PM Mini Gen3

1 Like

Ha Erik,

Thanx for the reply and the mqtt suggestion. I guess I’ll take that route for now.

Best regards, Jesse

Looks like the Gen 3 series support has been implemented recently. The associated pull request has been merged:

Is it possible to get these changes in OH 3.1 or do I have to upgrade to the latest OH version?

You will need to upgrade to 4.2 m1 (as soon as it is available) or switch to snapshot

I was afraid someone would say that. :worried:
I checked the docs and it seems a rather cumbersome procedure to perform that upgrade with high risk of something breaking. So I might eventually do that but need to be prepared to spend some considerable amount of time. Next time I buy some new hardware I better check the compatibility with my OH version.

Totally worth the effort if you ask me :slight_smile:

1 Like

Is there a difference between the “Shell 1PM Mini Gen3” and the “Shelly Plus 1PM Mini Gen3” ?

The Pull Request only mention the PLUS Version?!?!?!

Hi, I am also working to implement a “Shelly Mini 3G” via MQTT, unfortunatley I am having problems to switch it via openhab.

Reading the status is already working fine with the following code:

		Thing mqtt:topic:Shelly_Mini3G_Garage "Light" @ "Garage" {
			Type switch : power "Power" [ 

But unfortunately switching it dosn’t work as the “commandTopic” is not correct.
Can somebody help me on this issue?

Thank you :slightly_smiling_face:

Hi, this my working UI code:

UID: mqtt:topic:a65cab3f72:4a2737b998
label: Duschlicht
thingTypeUID: mqtt:topic
availabilityTopic: duschlicht/online
payloadAvailable: “true”
bridgeUID: mqtt:broker:a65cab3f72

  • id: Betrieb
    channelTypeUID: mqtt:switch
    label: Betrieb
    description: “”
    commandTopic: duschlicht/command/switch:0
    stateTopic: duschlicht/status/switch:0
    transformationPattern: JSONPATH:$.output
    off: “false”
    on: “true”


Best, Ralf

How can I get a jar file of this binding-update?
I am on OH 4.1.1 and real OH newbie.

Gen3 Shelly 1PM Mini’s encounter communication errors with 4.1 Shelly binding.

I installed the OH4.2.0 M1 Milestone with the latest Shelly binding updates implemented and it works properly with my Shelly1 mini G3 (not PM).

1 Like

I tried to implement your configuration in my setup, but wasn’t sure what to do with the last part?


Can you help me in the right direction?

You need to put a file called into the tranform folder in opnehab-config folder.
Content of the file is:

Now it works perfect. Installing the transformation service was the last I needed to get it up running. Thank you so much.

i can confirm that