Shelly Binding

Tags: #<Tag:0x00007f617093af20> #<Tag:0x00007f617093ae58>

This is a firmware related issue. Since 1.7 the power consumption is not reported correctly. The reported value is too low. You can see also 0 W in the device Web UI. Try to increase temporary all values to max, maybe is it enough to report a power consumtion > 0 and you will see it also in OH.
The issue was already reported to Shelly team.

Hello all! I have a question regarding Shelly 2.5 in Roller mode.

I’m using OH 2.5.2 an Synology NAS. I’ve created the THING via PaperUI. Roller Events and CoIoT Events are enabled. Firmware is 1.7.0.

How can I get real time roller events like “ROLLER_OPEN / ROLLER_CLOSE / ROLLER_STOP” and use this in my rules? I like to use this to tilt my blinds (venetian blinds). Right after roller stopped, tilt the blinds.

Like this:

rule "Shelly Event"
when
    Channel "shelly:shelly25-roller:f34aa0:roller#event" triggered
then
    logInfo("Shelly", "an event was detected")
//do some other stuff e.g. tilt blinds
end

Thanks for your support!

Hi Markus,

I got a few days ago the Shelly EM3 and have implemented it into OpenHAB.
The Shelly is updated to Firmware 1.7, but the behaviour was the same at 1.6.

I found the following issues:

  1. The reactiveWatts can not be addressed in OpenHAB as described in the description
  2. The values of L2 and L3 Power are changing every few seconds. L2 shows the value of L1 and L3 shows the value of L2, a few seconds later the right value is shown
  3. Total Energy: Approximate 1-5 times per hour the sum value drops from 46 to 6 kWh and later back to 46. The 6 kWh is the sum of L2 and L3. It looks like the L1 value is missing. A few time the value drops to 4 kWh which is only the value of L3
  4. Total Power: Also the Total Power shows approximate every hour a value of 0 which is not realistic.

In the Shelly App I cannot see this behaviour.

Please see a Chart of the Sum Values attached.

Peter

Rule looks good. Please check in the Web UI under Actions that a URL is set for those events pointing to your OH system (currently roller events are not supported by the Coap interface). Check you thing config if roller events are enabled.

1 Like

I need a TRACE Log showing those effects
Try to disable Auto-CoIoT in the binding config and disable CoIoT events in the thing config so we have only one source for channel updstes (REST polling)

Hey Markus! Thanks, that was it! It was the wrong ip-address in the actions url!
Now it is working!

Thank you for this great binding!

hmm, usually the binding sets this URL, where does the IP address comes from?

Good question :grinning:

I think I was connected via VPN or maybe via myopenhab account when enabling the roller event? Could that be?

usually the binding gets the setting from OH‘s network settings. Check PaperUI:Configuration:System:Network and make sure that the correct one is selected
re-enable Auto-CoIot in the binding config

Hey @markus7017,

I already have two of the new Shelly i3 devices. Can I somehow help you with integrating this device into the Shelly Binding?

sure, send me the output from
http://<shelly ip>/settings and
/status

After the update to 1.7 my Shelly1 are not working correctly anymore. I receive the error:
ERROR: Unable to process command ON for channel shelly:shelly1:12c00d:relay#output - Device unreachable or API Timeout ().

I tried to delete and rediscover but the devices are not discovered.

Same too

I have no Shelly 1 with 1.7

Does discovery works?
Does WebUI works?
Also problems with other commands?
Are Action/CoIoT events enabled?
Do you have other devices with 1.7?
Did you verified WiFi coverage?

Does discovery works? ??
Does WebUI works? No reaction
Also problems with other commands? Not in use
Are Action/CoIoT events enabled? Not in use
Do you have other devices with 1.7? 2.5, Dimmer
Did you verified WiFi coverage yes

Does discovery works? Not from openhab
Does WebUI works? Shelly web ui? Yes
Also problems with other commands? I use only on/off
Are Action/CoIoT events enabled? I have action enabled (on/off url)
Do you have other devices with 1.7? No
Did you verified WiFi coverage? Working without problems

try to disable Action URLs, I know that there was a change in 1.7, maybe this cases problems. If CoIot is enabled you din‘t need the action urls

How can I be sure thst Colot is enabled? I cannot find a setting for this in the webui. And what about the devices that are not discovered?

in the thing config Enable CoIoT Events
are you using the DEV build?

Some updates. I removed and readded manually all my devices (discovery is not working) and everything seems to work correctly now.