Shelly1PM switch does not provide switching channel in openHab Shelly binding

I am a newbie to openHab, so excuse my question. I have tried to search for the answer, but had no success.

I am using the latest openhabian on a Raspberry 4 and I am trying to switch a Shelly1PM switch with power meter. I managed to install and configure it to switch by the webpage of the device and by the Shelly App. However, when I create a Thing in openHab with the Shelly Binding, I see only a channel for the WIFI signal strenght and so on. I can also plot e.g. the device temperature, but I can not find a channel for the switching and the power meter.

What am I doing wrong?

Check the Shelly binding thread…
I think u need the dev version of the binding.

Currently I am using the version 3.3.0 of the Shelly Binding.

Try the dev build…
See instructions in the Shelly threat…

I have followed the instruction:

  • unstall the original Shelly binding
  • copy the tree files in the add on folder (shut down openhab etc.)
  • bundle:list says
    298 │ Active │ 80 │ 2.0.0 │ Californium (Cf) Element Connector
    299 │ Active │ 80 │ 2.0.0 │ Californium (Cf) Core
    301 │ Installed│ 80 │ │ openHAB Add-ons :: Bundles :: Shelly Binding Gen1+2

but I can not add a thing or see any binding?

There is a problem right now.
Join here.

I have the developer binding up and running, but a switch channel is still missing. The log file says: shelly1pm-34945470e4e5: Unable to initialize CoAP access (network error). Any idea about that?
May be it is better to join the discussion in the other thread.

I solved it. Within the Shelly binding the IP adress was set to the IP address of the shelly device, but this had to be changed to the IP adress of the raspberry pi. Now it is working even with the normal shelly binding (not the dev version). I learnd a lot, but it took me 1.5 days.

Nice. I’m glad that you’ve got it running.

Thank you for your help.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.