Shift work calendar integration to control heating

Hi everyone,

I have a running openhab2 installation on a RPi. Everything is working fine, rules are working etc.
What I am now searching for is a comfortable way to control my Homematic heating components. My girlfriend is shift worker so it is not easy to programm the heating as every day might be different.
She uses a google calendar to store her shift plan. So I integrated the google calendar addond, which works perfectly. But… every shift has to have the event to be triggered in the calendar description. So my question is if there is any way to just control the heating by the title of the calendar event.
For example:
Calendar entry with title “Early stage” as a whole day event.
Rule “Early stage” would be started (without any further start/stop event in the calendar description).
Is it somehow possible to do this? It should be somehow easy to control without adding event descriptions.

Thanks for help!

I think the CalDav binding can do this.

Hm, google tells me that the endpoint “” is deprecated. Is there any newer tutorial how to use it?

All I know is lots of people are using CalDav with Google Calendar.

The following URL has the instructions for how to set it up. Perhaps Google removed that API recently.

According to, the CalDav itself isn’t deprecated, just that particular end point.

Yes and it looks like I cannot connect to the new endpoint with client id and password…

Do you have 2 factor enabled on your google account? If so you need to create an app specific password.

I’ve not seen any reports that CalDav is not working with gmail and as little as a couple months ago I saw postings with working CalDav with google.

It looks like the same problem as mentioned here: Caldav google calendar problem
I wanted to avoid saving username and password in config file but as seen there this seems not working?

Edit: with old caldav endpoint and username password it seems to work but I think this is not the best solution…

Edit2: or not, a few minutes later I got a not authorized…