Shutdown command in WOL binding not working

Good morning everyone. I have created this item definition in wol.items inside items folder to be able to turn on and off a server “on demand”. This is the statement…

Switch WOL_Network_Sora “Server Sora” (status,network) { wol=“”, exec=">[OFF:net rpc shutdown -I -U PowerMAN%%bloblobloblo -f]" }

…and this is in my sitemap.

Default item=WOL_Network_Sora icon=“qualityofservice”

It’s almost a copy-paste from the wol example available on the openhab wol binding page.
The wake on lan part of the switch works as intended.
The shutdown command works perfectly if I type it in using an SSH session into openhabian, but seems to have no effect in the item description. Any clue?
Thanks for your kind help!
Have a nice day!

Cesare Giuliani

Dumb question, did you install exec1 binding ?

binding-exec - 2.4.0

This is the one I have found on the repository of my openhabian…am I using the right one?
Thanks for your answer

No, thats the 2.x Binding, but your config uses 1.x Binding
You can install exec1 binding through PaperUI after you have enabled legacy bindings.

1 Like