SIGAR for Mac OS X

I’m trying to get the System Info binding and sigar running in beta 2 on Mac OS X. I’m getting this error:

no libsigar-universal64-macosx.dylib in java.library.path
org.hyperic.sigar.SigarException: no libsigar-universal64-macosx.dylib in java.library.path
	at org.hyperic.sigar.Sigar.loadLibrary(
	at org.hyperic.sigar.Sigar.<clinit>(
	at org.openhab.binding.systeminfo.internal.SysteminfoBinding.initializeSystemMonitor(
	at org.openhab.binding.systeminfo.internal.SysteminfoBinding.updated(

I have tried to place the libsigar-universal64-macosx.dylib file from the zip download at sourceforge into these folders:


But the same error keeps showing at startup.

What is the right path for the library and how to get it running?

Ought to be fixed in b3 (1.9 binding now packages and loads native libraries by itself), or try the new OH2 system info binding.

I installed the offline beta 3 and the error still shows.

Odd. Could you try the one here?

Making sure the old one is uninstalled first.

I installed beta3 by copying back my […]/userdata and […]/conf folders over the beta3 ones.
I can’t see any bindings in the paper UI.

Could this be a cause?

What is the best way to install beta 3 over beta 2?

I wonder if this thread helps answer your question?

I will create an update script first and then check the SIGAR library again. Thanks so far, @watou

Took the time to create a script to get the snapshot build. All credits go to @xsnrg for his excellent makeHAB script.

I then enabled the systeminfo binding in the addons.cfg and the SIGAR library seems to be working out of the box.

1 Like