Simple HTTP Binding configuration for rollershutter controll not working

Hi guys,

up front I want to apologize, there might be a very easy answer to my problem. However, I’m not experienced with HTTB Binding in OpenHAB (Version 3.4.1) and just cannot figure it out.

For my roof window shutter I use the controller ShutterboxDC.

It is connected via Wifi to my network. With the App the controller is working perfectly fine.
It also has an open API that is documented here.
This is also working fine. For instance, when I paste and send the URL http://[LocalIP]/s/u in my browser the shutter goes up (see in the docu). Without any special authentication.

So, now I want to use the HTTP binding to steer the controller via OpenHAB. For that I did these steps:

1. Create a HTTP URL Thing
As base URL I entered http://[LocalIP]/

2. Create a channel in the HTTP URL Thing
In that thing I created a “Rollershutter channel”
Status and command transformation I left empty
as “Up” Value I set “s/u” → Becaue in my browser the URL request http://[LocalIP]/s/u made the shutter move up.
For Down I set “s/d”
Für Stop I set “s/s”
Move I left empty since there was no matching parameter.

3. The channel I connected to an Rollershutter point Item.

In OpenHAB everything looks good. The thing is online.
But when I click in the arrow up in the item, nothing happens.

What is wrong here? I have no idea where my mistake is.

Thank you very much for the support.

see here

Hi @Oliver2,
Thanks for your reply. However, I do not get how the linked solution could solve my issue because I do not have such variables in my URLs.
Could you please help me to transfer the linked solution to a solution of my problem. I do not get it :smiley: Do you think my problem is rooted in the base URL?

I assume “u” is the command for “UP”. In this case the base url is:

UP value: u
DOWN value: d
STOP value: s

However, I do not know where to enter these data. Your screenshot also looks different fron the one I was linking to. Your http binding provides you probably with several ways to get things done.

Ah, now I see :slight_smile: Thank you.
I’ll try and will give feedback.

1 Like

Unfortunately, it took a little while until I had the time to try this again.
In the meantime I swiched to textual configuration of openhab. Nevertheless, your hind was very valuable and helped to configure the http thing correctly:

Thing http:url:ShutterOGZi "Shutter-OG-Zi" [ baseURL="", refresh=1] {
         Type rollershutter : Steuerung "Steuerung" [ commandExtension="%2$s", upValue="u", downValue="d", stopValue="s", stateTransformation="JSONPATH($.shutter:currentPos:position)" ]

Thank you!