Sitemap 'default' could not be found (Classic & Basic UI)

  • Platform information:
    • Hardware: VM Raspberry pi
    • OS: Debian 8
    • Java Runtime Environment: openJDK 11.0.6
    • openHAB version: openhab2.x
      Hi everybody !

I decided to install OH 2 in my raspi VM and the installation was ok but when I tried to make a sitemap as simple as it is :
sitemap default label=“Exemple”

  •    Text label="Hello"*
  •     {*
  •     }*


It doesn’t work… With Basic UI I have “no sitemap available”
and with Classic UI I have “Sitemap default could not be found”

Of course my sitemap is located /etc/openhab2/sitemaps/default.sitemap
Do you have any idea ?
Thanks !!

OpenHAB 2 is designed for Java 8 not 11. OH 3 uses Java 11 but it is not yet in a stable release.

my bad its openJDK 11 not java 11. Does it make any difference ?
Also I remember having already worked with OH2 with openjdk11

That is based on Java 11.

OH2 parts work with Java 11 but are designed to work with Java 8. Zulu openJDK is the most recommended product.

Ok thanks, then I’m going to uninstall openjdk 11.0.6 to install zulu I’ll keep you in touch

Mmm I uninstall openjdk11 for zulu openjdk8 but I stille have the same error …

If you are running a Raspberry Pi why not use the openHABian image? That makes things a lot easier.

Have you looked at /etc/openhab2/conf/ ? You should find a readme.txt in the correct folder, for confirmation.

1 Like

Bc its a VM, not a physical raspeberry pi

In order to run a Pi VM the underlying hardware must be the same kernel architecture though, correct?

I did not know a Pi VM existed.

How you installed openHAB determines where the config directory is located.

I dont have the conf foalder in oh2

It actually exists and I already worked with OH2 on a VM raspberry. This is the first time the UI cannot find my sitemap