Sitemap - UI generates Entry causing Error in Editor

Hello there.
I just recieved an harmony hub and wanted to create a sitemap button to controll it. As discribed in the docs i created a simple Switch with the required actions as mappings (via UI not the Editor) and every think worked perfectly.
A few days later i was working on the same sidemap again but was using the editor instead of the ui. Unexpectetly the editor was showing me an error in a line i didnt even changed. After some tests i could narrow it down to the button mentioned above.
Actually the error message is quite obvious. The problem is that the command of the command-value-pair for the button-mapping is containing an space and the editor cant handle that.
To fix the problem i tried to quote the command just like the keys were and this fixed the error generated by the editor. But after this change the sitemap-button didnt work any more (probably because the wrong commands were send to the item).

If thats not a bug but me doing something wrong i would be happy if anyone could tell me how to do it right. Otherwise if you agree with me i can create an issue for this problem.

Also it would be nice if someone whos running a version of Openhab 3.2.0 could try to reproduce it to check if the error is still there. The code needed for the sitemap switch can be found down below.

  • Platform information:

    • Hardware: PI4
    • OS: Raspbian
    • Java Runtime Environment: 11
    • openHAB version: 3.1.0
  • Please post configurations (if applicable):

    • Items configuration related to the issue
      Can be provided later if needed.

    • Sitemap
      Switch mappings=[Fire TV=“Amazon”,Fernsehen=“TV”,Musik hören=“Musik”]

    • Error generated by Editor:

      Error: Syntax error at line 3 col 26:
            Switch mappings=[Fire 
      Unexpected WS token: " ". Instead, I was expecting to see one of the following:
      A equals token based on:
          Mapping → MappingCommand ● %equals MappingLabel
          Mappings →  ● Mapping
          WidgetAttrValue → %lbracket _ ● Mappings _ %rbracket
          WidgetAttr → WidgetAttrName ● WidgetAttrValue
          WidgetAttrs →  ● WidgetAttr
          Widget$ebnf$1 → Widget$ebnf$1 ● WidgetAttrs
          Widget → %nlwidget _ ● Widget$ebnf$1
          Widgets → Widgets _ ● Widget
          Sitemap → %sitemap _ SitemapName __ SitemapLabel __ %lbrace _ ● Widgets _ %rbrace
          Main → _ ● Sitemap _

It doesn’t like the naked space character.
Try ["Fire TV"= ...

The GUI sitemap editor is not yet perfect. Existng issue -

Well thats exact the problem i am facing. Didnt found this issue before. I will discuss all other there, thanks!