Sitemap Weirdness

Tags: #<Tag:0x00007fc8f8e36b38> #<Tag:0x00007fc8f8e36a70>

I have an item on a sitemap that reports the level of my son’s ipad battery level using the icloud binding.

When the sitemap loads, the value is correctly stated and then the value changes to a much lower value. If I refresh the browser, the correct level shows for a brief period of time and then reverts to the incorrect reading.

Any idea on what could be causing this?

Here’s a screencap:

batt_level

The item is a number item.

Sitemap and item code, please?
Anything in the logs when that happens?

Nothing appears in the logs when it changes…

Item

Number ZiPadBattery "Battery Level [%.0f%%]"  <battery> { channel="icloud:device:zaneicloud:xxxxxxxbatteryLevel" } 

SiteMap (this is the first Frame of it - the item in question is #4)

sitemap testing label="5517 Test" {
    Frame label="Home Information"{
		Text item=MailboxProxy label="Mail Is:[MAP(mailbox.map):%s]"
		Text item=BYPRoute_Data
		Text item=HomeRoute_Data
		Text item=ZiPadBattery
		Text item=poolpump_psi
		Switch item=MQTT1
		Switch item=TV_LIVINGROOM label="TV Power" mappings=[TV_ON="On", TV_OFF="Off"]
		Text item=RtGarageDrSensor2
		Text item=WUTemperature icon="temp2"
		Text item=WUHumidity
		Text item=WUConditions
		Switch item=JunkIn2
		Text item=Calendar_Upcoming_Junk
		Text item=Calendar_Upcoming_Trash
		Text item=Calendar_Upcoming_Tree
		Text item=Calendar_Upcoming_Recycle
		    }

Have you tried changing its place in the sitemap?
Or removing it from the sitemap and then adding it back in?

I did both…

I moved the item in question to a different position on the sitemap and it is now working as it should…the issue is now that the items that took it’s place in the sitemap is experiencing the same issue. The value is correct and then about 10 seconds later it changes.

I tried removing the item and then bringing it back with no success.

Any other ideas?

Next step:
Clear the cache

Is the item actually changing value (i.e. do you see it changing in events.log)? I doubt it, but best to confirm.

Not sure which browser you’re using. Did you try it in other browsers? Does the same behavior occur?

Can you bring up developer tools in the browser? On the network tab, do you see any network activity that would indicate state changes being sent from the OH host?

Be suspicious of the preceding Item in the sitemap, possibly includes control characters or something?

1 Like

Yes - tried in multiple browsers on multiple machines…still see the same behavior

Yes I am seeing the following:

The first line is the correct value of the state, the second is the number it’s changing to

@mhilbush Mark any more ideas?

What do you see in events.log? Is the item changing state/value?

So, is it always the Item that follows HomeRoute_Data that is poorly, or always the fourth Item, or?

Nothing in the event log.