Slider for KNX-Dali dimmer jumps at first always to 100%

If i use the slider for an KNX-Dali dimmer, the slider jumps at first always on 100%. This is regardless of which value i choose for the dimmer.
In the events.log, i could trace the problem so far, that i can see, that the dimmer item at first becomes the right value (line 1-5 in the events.log), but immediately also the switch switches to “ON” and the slider jumps to 100% (last line of the events.log).

here is the events log:

2021-02-24 00:42:25.382 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Licht_WoZi' received command 53
2021-02-24 00:42:25.397 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'Licht_WoZi' predicted to become 53
2021-02-24 00:42:25.426 [INFO ] [openhab.event.ItemStateEvent        ] - Item 'Licht_WoZi' updated to 53
2021-02-24 00:42:25.430 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Licht_WoZi' changed from NULL to 53
2021-02-24 00:42:25.571 [INFO ] [openhab.event.ItemStateEvent        ] - Item 'Licht_WoZi' updated to 53
2021-02-24 00:42:25.601 [INFO ] [openhab.event.ItemStateEvent        ] - Item 'Licht_WoZi' updated to ON
2021-02-24 00:42:25.609 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Licht_WoZi' changed from 53 to 100

It seems to be a OH problem, because the state ot the dimmer position is right, but the slider shows 100%. Also the value in the KNX is right (53%).
If I use the slider again, the it shows the right value. But I have no idea, why the switch switches to “ON”, or how to solve the problem.

I guess, i have the problem since i installed OH3 (from OH2.5 before), but i’m not sure.

the dimmer item:

Dimmer Licht_WoZi  "Licht_WoZi_Decke_Innen_Dimmer [%d %%]"    { channel="knx:device:knx-ip-gateway:knx:Licht_WoZi" }

and the dimmer thing:

Type dimmer 	: Licht_WoZi  "Licht_WoZi" 		[ switch ="1/3/80+<1/3/83", position="1/3/82+<1/3/84", increaseDecrease="1/3/81" ]

and the Sitemap:

Slider item=Licht_WoZi  

See in particular “Jitter”

but I think in this case the ON that gives the effect of 100% is coming from here
[ switch ="1/3/80+<1/3/83",
i.e.dimmer reports ON and binding converts to 100%.
Try it with
[ switch ="1/3/80",
so that you rely on dimmer numeric position reports only.

1 Like

good idea.
And yes. it works. :slight_smile:

But is it just a singularly problem in my case? Or does somebody else has these problem too? especially in connection to KNX?

I think it’s a peculiarity of (some?) KNX dimmers to send separate report of on/off and %.

Sure.

I confirm I had the same (or similar) problem (and I am still on OH 2.x as I do not dare updating) and the solution suggested by rossko57 worked fine; the only thing I lost is a real time update of the slider when I move it (I need to wait a fraction of a second till I see the effective percentage).

You might get better visuals with autoupdate enabled. But there will be a trade off against possible “jitter” when using ON/OFF instead.