SMA Energy Meter binding stopps working after update: Address already in use (Bind failed)


today night my sunny home manager 2.0 has been updated automatically to 2.03.4.R. The update was successfull according to the sunny portal log. But unfortunately also the SMA Energy Meter Binding stopped working: I don’t receive any new data in openHAB.
I can see new data in the sunny portal but no updates on my openHab items.

This is what i have tried so far:

  • Removed the automatically discovered SMA Energy Meter thing
  • Tried to add it again by automatic discovery, first without success, needed to unplug the network cable and replug it again to make it discovereable
  • Then i got a few values but short while after i receive the same binding error as on my investigation in the morning: “Status: OFFLINE - COMMUNICATION_ERROR Address already in use (Bind failed)”
  • Also checked using wireshark that the broadcasts are sent every second
  • Changing the IP address of the Home Manager also doesn’t help

I am not sure what causes this problem and i wonder what causes the collision.
Which address is the problem? The multicast address?
The IP adress of the my home manager is used only once when i check the clients of my router.

Any ideas or similar problems for other users? How can i debug this more in detail?

Solution: I am pretty sure i found the reason:
I run daily crontasks of the SBFSpot to get data from my solar inverter. The task is running every 5 minutes. It seems that during the update the task did not return properly and still was blocking port 9522 (checked sudo netstat -l -p --numeric-ports | grep 9522).
After killing the old process i was able to run the SMA Energy Meter Binding correctly again without any interruptions so far.
But i still wonder why initially (after replugging the network cable) i got some values even though the port was blocked…