Small bug in Setpoint with limits on sitemap?

I am using Habian on Debian 9 on a laptop (so Habian not on Rpi). I am on snapshot OH2.4.
Today I set a setpoint on my sitemap that I use to update a zwave radiator-thermostat with the setpoint of my livingroom-thermostat minus ‘X’. The ‘X’ is set in an admin area, with the following item:


Number Radiator_Gang_Tset_verlaging "T < Woonkamer" <heating> 


Setpoint item=Radiator_Gang_Tset_verlaging minValue=-2 maxValue=0 step=0.2

When I ook in the Sitemap on my app, I see the following choises:

0.0  -0.1999999993  -0.39999998  -0.6  -0.79999995 -1  -1.2  -1.4   -1.6   -1.8   -2

Not a big problem, but not exactly what I want either! Is there a workaround, or should I do a bug report (or is this a known issue?).

Same here, just tested.
Even more weird: BasicUI does show for example
and the Android app does show 0.6

I guess this is a bug …

Have you tried formatting?
%.1f should do the job

1 Like

Did not think of that :sunglasses:
This solved it for my test item in BasicUI, but not for the Android app …

That is a good idea. But isn’t that funny: [%.1f °C] solved it for all but one value! I still have 1.8000001 !