Smarthome/J Tuya Binding for openHAB 4

Hi All,

Any one to help on that topic?

Is there any other tests to do or logs to get?



I believe the way that I got from 3.4.4 to 4.0 successfully with the smarthome/j Tuya and amazonechocontrol bindings I use was:
Backuped my 3.4.4 install
Created a new clean OH 4.0 install using openhabian to move to java 17
Downgraded OH to 3.4.4. (I did it before the release, so I just used openhabian-config - now you might have to figure out how to tell openhabian to install 3.4.5)
Restored the backup.
Waited for the OH 4 release
Using openhabian-config, upgraded to 4.0 (done this way to take advantage of the upgrade script that does things like handle the UoM changes that you will miss if you just restore your 3.4 to 4.0)
Smarthome/j bindings did not work after this.
First I tried updating the 3rd Party add on service to The Smarthome/j bindings appears, but I got an error when I tried to install them.
I changed 3rd Part add on back to the earlier setting (I don’t remember what it was). I then was able to delete the existing bindings.
Then I returned the 3rd Party add on service to I was then able to install the 4.0 bindings and they worked.

I think the key was deleting the old bindings, that seems to be in an in between state.

I installed the Smarthome/J snapshot binding ( on 4.0.2. When creating the Tuya Cloud Project I get the following error:

What am I messing up?
I tried on versions 3.4.5 and 3.4.0 with the line

I found in openhab.log: Cannot create thing. No binding found that supports creating a thing of type ‘tuya:project’.

Hi All, does Smarthome/J Tuya Binding support profiles?
I’m asking because my temperature sensor shows

even after I did configure divide by 10.

After several restarts the value gets divided by 10. I cannot recall any other related changes!?

Profiles are a core feature and should be available on every channel.

I have tried to install the Tuya Binding, but I received an installation error both on a fresh install and an upgrade done from a previous version of Openhab 3.4.5. I am currently on 4.1.0 M2. Any ideas?

What type of error?

Hi JNK. The error is that binding cannot be installed.

Server-side issue. Please try again in 30 minutes from now.

Thank you. Will try when I get time.

Anyone knows the sintaxe for things config file? (text config files).


Got it working. Thank you so much.

Hi. I’m unable to install the binding. OpenHAB version 4.0.3 - Release Build

Tried both console:
openhab> bundle:install
Bundle IDs:
Error executing command: Error installing bundles:
Unable to install bundle org.osgi.framework.BundleException: OSGi R3 bundle not supported

And from the GUI. When installing from GUI I get the following:

Installation of add-on marketplace:150699 failed

Any ideas how to proceed? Iäm using the snapshot repo.


Why don‘t you use the JSON 3rd Party Marketplace? That is the recommended way to install it. Add and be happy.

I have added that to the Settings, as mentioned above. And I get the " Installation of add-on marketplace:150699 failed" error when installing.

1 Like

But an add-on with the marketplace: prefix is from the community marketplace (in this forum). If you scroll down, you should see a section labeled “Other add-ons”. Pick it from there.

I’m feeling unusually stupid atm… I have added:
to the “Json 3rd Party Add-on Service” setting. It said somewhere that you should use that for OH4, instead of just addons.json. So let’s start there: which one is correct? I tried both with the same error.

And now for the Bindings installation menu: I only see “openHAB Distribution” and “Community Marketplace”. When I search for “tuya”, I get one hit. WHICH I know realize, gives me an entirely different Binding called “Smarthome/J Tuya Binding support for WIFI TUYA Energy Meter 63A”

So sorry about this, entirely my fault for not noticing this before. I couldn’t see the “Other add-ons” option, but I have now found the option that enables it and can now see the plugin.

And it installed fine. Thanks for pointing out some details which lead me to figure out the problem.

1 Like

No. addons-snapshot is for openHAB versions where no release is available (i.e. 4.1 at the moment). For openHAB versions that are a release (i.e. 3.4.x or 4.0.x) use addons.

Suggestions how to add a Tuya-based device without auto-discovery?
I have an infrared panel installed in my office and using the Smarthome/J binding I created the Thing which is showing as online. So far, so good.
But, since my OpenHAB instance is running in a different subnet (and in a pod/container) I cannot discover it automatically.
And since I use configuration files (instead of UI) I was wondering how a Channel configuration would look like. Does anyone have any hints?

UPDATE: After restart the ‘WiFi Thermostat heater’ shows up as discovered Thing. My last question still stands: thoughts on Thing/Channel definitions using config file?
To try and figure out the configuration (deducting from the YAML code generated via Main UI when adding Thing), I added the discovered Thing manually and added the IP address and protocol version (used 3.3), which brings the Thing ONLINE.