Smartthings binding openhab3 issue

I am slowly improving the home automation integration and have been playing with openHAB2 as a potential replacement for my Smartthings Hub (V2) and latterly as a bridge between Smartthings and a fledgling Drayton Wiser heating control (still more to invest in this).

I recently installed openHAB3 as a clean build on an old RaspberryPi2 (v1.1) under Raspbian with the boot set to redirect to a SSD. This configuration worked with openHAB2 and with the exception of the Smartthings binding seems to be working OK with openHAB.

My first attempt to make the binding work I left the Smartthings SmartApp and Device Handler unchanged - the openHAB hardware was unchanged and there is no new version of the software on github. Just downloaded and configured the Smartthings binding as per the documentation and ran ‘scan’. The scan appeared to happen (at least the progress bar progressed) but when it ended there was no inbox message and no new things.

I tried various combinations of restarting devices, reinstalling software and finally removing all binding components in both Smartthings and openHAB and rebuilding from scratch, all to no avail. Any suggestions for what to try next?