Smartthings motion

I have a Smartthings motion sensor that should report motion, battery level and temperature. The sensor is discovered using the Zigbee binding and is identified as ‘Smarthings motionvv4’ however it sets up only two item links; motion/intrusion (works correctly) and illuminance (the sensor does not measure illuminance) it does not set item channels for temperature or battery.
Any suggestions?

In PaperUI, when linking channels, is there a “show more” option to click on? I think it’s on the right side of screen but not 100% sure.

There is a icon like a up and down arrow that if clicked will expand a area ‘Linked Items’

The “show more” will be straight across from “Channels” if available. Not all things will have this option just asking b/c others have ask about missing channels (other bindings) and they where listed after clicking show more.

@Dave55: this is quoted from @chris and may help with your device as well.

  1. During initial inclusion - the device must be kept awake by pressing the button every second or so while the binding reads all the basic information - this may take 10 seconds or so.
  2. When the device is created as a thing - this is when you go to the inbox and click the create thing button. At this time, the binding does a bunch of configuration to detect the channels and configure the device - again, during this phase the device should be kept awake by (I hope!) pressing the button again for another 10 or 20 seconds.

Show more not there. So I will remove and retry with your suggestions.

Did not change anything. I tried with two different sensors

I am trying to get the new SmartThings motion sensor recognized with no luck. The more rounded one Model: IM6001-MTP15. Tried many variations of reset and holding the button but does not recognized properly. Shows up as unknown…

Some errors from the logs:
2020-06-23 15:21:16.441 [ERROR] [verter.ZigBeeConverterBatteryPercent] - 286D970001074631: Error 0xffff setting server binding
2020-06-23 15:21:26.237 [ERROR] [ng.zigbee.handler.ZigBeeThingHandler] - 286D970001074631: Exception creating channels
java.lang.NullPointerException: null
at org.openhab.binding.zigbee.internal.converter.ZigBeeConverterTemperature.initializeDevice( ~[bundleFile:?]
2020-06-23 15:45:59.896 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 286D970001074631: Manufacturer request failed
2020-06-23 15:46:11.897 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 286D970001074631: Model request failed
2020-06-23 15:46:23.897 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 286D970001074631: Hardware version failed

Anyone get these working. I deleted and re-added the thing so many times I think it is now just confused.

What version of the binding are you running? I’ve got 2.5.9 running and the Smartthings 2.5.9 that is part of that build works great for me. I’ve got 2 door/window sensors and a multisensor all working great.

I can assure you they were not running that version 4 months ago. I expect 2.5.4 or 2.5.5 was the latest then.

Guess I will try an upgrade then

Finally upgraded to V3. Leak, Multi/Door sensor and sonoff zigbee plug all working fine.

However, my motion sensors are reporting NULL for the Motion Presence channel??

Any ideas?


This probably means that there is no reports being received - either the initialisation didn’t work correctly, or the binding isn’t decoding them. Probably it’s an initialisation issue since the binding is the same as 2.5, so if it worked there, it should be fine.

I’d suggest checking the debug logs to see if the reporting is working, alternatively, take a look at doing a reinitialisation (be sure to wake up the device so it can initialise properly :slight_smile: ).

I tried about 5 times today with no luck. The last time I reset it and then kept it active by pressing the button every second for about 20 seconds until it showed online. But motion is still showing null :frowning:

I turned on debug log but am no expert in ZigBee. I don’t see anything really bad. I do see some state=FAILED and state=CANCELLED?

By reinitializing I have been removing and then re-scanning. Is that what you mean? I have attached the debug logs.
openhab.log (644.0 KB)

Hope someone can figure this out I don’t like relying on the SmartThings hub as my network is not so good.


I don’t know why it’s saying null - the log seems to indicate that it is being decoded correctly.

I don’t see anything in the logs that indicates it hasn’t updated the state. Maybe there’s a mismatch in the types? How have you configured this?

Mapped to Item with:
Type: Contact
SemanticClass: OpenState
SemanticProperty: None
Profile: (No Profile)

Should the type be switch? I thought I tried that yesterday.

Thanks for your help and identifying the log entries to look at. I noticed the _motion was always off. Seems that the _intrusion is the one going on and off.

I got it to work by linking a SWITCH to _intrusion. a Contact type did not work kept saying null.

Seems to be working now - showing on/off rather than open/close but that is fine.

Thanks again