Snapshot release dead


after I updated my install of OpenHAB 2/Snapshot (online version) with apt-get update/upgrade today, OpenHAB doesn’t run anymore.The log shows the following error:

2017-01-17 09:56:10.604 [WARN ] [raf.features.internal.osgi.Activator] - Error starting activator Unexpected end of input at 1:1 at org.apache.karaf.features.internal.util.JsonReader.error([8:org.apache.karaf.features.core:4.0.8] at org.apache.karaf.features.internal.util.JsonReader.expected([8:org.apache.karaf.features.core:4.0.8] at org.apache.karaf.features.internal.util.JsonReader.readValue([8:org.apache.karaf.features.core:4.0.8] at org.apache.karaf.features.internal.util.JsonReader.parse([8:org.apache.karaf.features.core:4.0.8] at[8:org.apache.karaf.features.core:4.0.8] at org.apache.karaf.features.internal.region.DigraphHelper.readDigraph([8:org.apache.karaf.features.core:4.0.8] at org.apache.karaf.features.internal.region.DigraphHelper.loadDigraph([8:org.apache.karaf.features.core:4.0.8] at org.apache.karaf.features.internal.osgi.Activator.doStart([8:org.apache.karaf.features.core:4.0.8] at[8:org.apache.karaf.features.core:4.0.8] at java.util.concurrent.Executors$[:1.8.0_111] at[:1.8.0_111] at java.util.concurrent.ThreadPoolExecutor.runWorker([:1.8.0_111] at java.util.concurrent.ThreadPoolExecutor$[:1.8.0_111] at[:1.8.0_111]

I tried to switch to the beta and changed the repository for apt-get, but I don’t get any updates - probably because the latest snapshot (installed) is more recent than the last beta.

Can I uninstall and reinstall OpenHAB somehow to change to the beta and get it working again, without loosing my existing configuration?



I got the same problem. For me it helped to switch to OH2 b5.

First, remove all content from /etc/apt/sources.list.d/openhab2.list

Then, add the Beta Repo:
> echo ‘deb testing main’ | sudo tee /etc/apt/sources.list.d/openhab2.list

Try to do an update. I guess it won’t work, so you need to make a backup of your OH2 configuration. Follow the steps from “Backup and Restore”. Then delete OH2, re-install (it will take OH2 b5) and maybe you need to restore your backup - for me the config files haven’t been removed.

Good luck :grin:

That shouldn’t be necessary, the snapshots moved repo. See

Note: the testing repo mentioned above contains the newly announced RC1

Excellent, thank you! After I changed the repository, I was indeed offered an update (openhab2-online), and after this I was able to start OpenHAB again. After this, I made the switch to “openhab2”, which also worked fine and also kept my existing config.

Thanks for the help!


1 Like