Snapshots 1593, 1596 and 1597 are useless (for me). Does anyone really care about Windows compatibility?

  • OS: Windows 10 Home, 32 bit, Windows 10 Home, 64 bit, Windows 10 Pro, 64 bit
  • Java Runtime Environment: jdk1.8.0_161 and jdk1.8.0_201
  • openHAB version: Snapshots: #1593, 1596, 1597
  • Issue of the topic: AmazonDashButton, AllPlay not running on Windows in above mentioned versions.

See also this topic!

Hello folks!

I have the impression that since the ESH core has been rebuilt into the openhab core, no one is bothering whether various bindings also work in Windows. This is a pity and really annoying.

Have now tried all the last three available snapshots. All useless for me. I’ve once downloaded the snapshot # 1555 (but deleted again from my harddrive). There AllPlay and AmazonDashButton worked.

Can someone please provide any between #1555 and #1593?

Thanks a lot! :slight_smile: Very much appreciated! :slight_smile:

Well, snapshot is a snapshot. Useless or not. Don’t want to sound rude but why don’t you stick with something that works? Why have you deleted all those earlier working versions?

IMO don’t think it’s about bothering. The latest modification to build environment and esh core integration has been alot of work.

Snapshots are where problems like these are discovered so they can be fixed. Your reporting the problems is exactly what you should do when you encounter errors like this in any version of OH. Thank you for reporting. I haven’t read the linked to topic yet but can I assume that an issue was filed?

But if you expect the Snapshots to be error free or to interpret errors you discover in the snapshots to mean that the developers don’t care about any particular binding or platform your expectations from the snapshots are unreasonable.

We have been spoiled a lot by the fact that OH 2 was so stable for the past year or so that perhaps we have grown to expect the snapshots to not experience these types of errors. But it is important to realize that it isn’t until the nightly builds and the snapshots that all the changes from all the teams contributing to all the github repos first come together. With a change as big as the merge of ESH back into OH, there is going to be many problems like these.

It has been repeated many times on this forum that the snapshots are not suitable for production use right now and will not be so until the next milestone is released. So only run the snapshots if you are willing to serve the role of tester which means risking errors and diligently reporting errors you encounter.

So what can we do as users? Report problems we see like these and file issues. Without the issues the developers may not become aware there even is a problem. It’s not like each and every developer has an RPi, Windows machine, Mac, QNAP, and Synology to test every change they make. They rely on us to help test and report problems by running the snapshots.

If you are not willing to do this, then you should be running the Milestone builds or release builds. If you are willing to do this, please do not interpret errors seen in the snapshots as neglect or malpractice on the part of the developers. That is unfair and unreasonable.



I know all about this. I just want to point out that there are the errors, but probably not be taken seriously, because it is a minority problem (just Windows). I switched back to my stable version. So no problem for me. Have certainly already used 30-40 different snapshots that did not cause any problems. Also did not want to insult or blame anyone. Sorry :slight_smile:

1 Like

I’ve installed it (#1555) only for testing something. After the tests, it was no longer necessary.

I did not want to attack or blame anyone personally. Of course, I appreciate your voluntary work very much. Many Thanks! :slight_smile:

1 Like

Back to my original request:

…or provide a link to download?

I searched here and there but could not find an older one …

Many Thanks! :slight_smile:

It more looks like some issues got introduced in the add-ons you’re using during the bnd migration. So those won’t be fixed by using another runtime since it downloads them from the online repo (unless you’re using KAR files).

But I’ve uploaded some of my cached snapshots anyhow using WeTransfer :slight_smile: :

These will probably be automatically deleted after a while.

1 Like


Thanks a lot. :slight_smile: I’m going to download them this evening. I’m in Darmstadt on SmartHomeDay at the moment.

1 Like

I’ve downloaded them, thanks a lot. :slight_smile: I will try out.

Afaik no maintainer or developer is on Windows. Your report is therefore quite valuable to fix Windows issues.

Usually because of the nature of Java, OH should run everywhere as long as a jvm (java virtual machine) is available. But allplay for example uses native libraries and the Windows dll’s are untested then.

1 Like

Sometimes I spin up a Windows VM to investigate something or help someone. :smile: Users running openHAB on Windows seem to be very rare (6%) according to the community survey. So you might be the first one to find and report these Windows OS specific issues.

1 Like

I also use Windows and have since 2.4. I’m currently running 2.5M1 for the MQTT Homie support. I am experiencing some issues with MQTT, but haven’t had time to post. Hopefully I’ll get some time soon.

As it relates to milestone builds post 2.5M1, I can’t get any of them to function enough for my usage. I’ve tried 2 or 3 recent ones. So far 2.5M1 is good enough for me until the next major Rev is released.

1 Like