Snmp binding - items stay empty

Hi there

I would like to get some information from my network devices by using the snmp binding. Currently I try to get the uptime from my firewall.

I have some problems getting the snmp binding to work. After changing the port to 1030 in the snmp.cfg i finally see something going on by tcpdumping on port 1030.

08:48:34.856218 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 76)
    10.4.4.254.snmp > 10.4.4.111.1030:  { SNMPv1 { GetResponse(33) R=2108097992  system.sysUpTime.0=2436890100 } }

As you can see, i get an answer with the correct uptime. But if i list the items in KARAF, the FW_Uptime is still State=NULL

openhab> items list
fwTS_UpTime (Type=NumberItem, State=NULL, Label=FW Uptime, Category=null)

The item in the items file looks like this

Number fwTS_UpTime “FW Uptime [%d]” { snmp="<[10.4.4.254:public:.1.3.6.1.2.1.1.3.0:10000]" }

And on the sitemap

Text item=fwTS_UpTime label=“test [%s]” icon=“network”

OH2 is installed on Raspberry Pi.

Version OH2 2.0.0-SNAPSHOT Build#526

Thanks for your help.

Item type Switch can only be ON or OFF, you need to use Number.

Thank you pensionado

I just changed the switch to number. unfortunately, the item still has the state NULL.

Did you follow the guidelines in the SNMP binding for setting up to correct binding ?.
BTW I didnt change any ports and it is working like a charm.

One of my items look like this:
String Rtr_uptimeFormatted "Router running [%s]" (System) { snmp="<[192.168.88.1:public:.1.3.6.1.2.1.1.3.0:60000]" }

and this works without changing ports.

Got it. Thanks.
I had Number in the item instead of String.

Thanks a lot