SNMP Binding not working on windows 10

Hi there! I just installed OpenHab today (Newbie).
I’m trying to get a value from a temperature sensor in my datacenter that uses SNMP
Device IP:

so I’m using this item:
Number RDU_Temp “RDU TEMP” { snmp="<[]" }

and adding this on sitemap:
Text item=RDU_Temp label=“RDU-A Temp” icon=“temperature”

I don’t get any value, just the frame indicating RDU-A Temp.

On the LOG I get:
2018-05-01 21:10:30.558 [ERROR] [ab.binding.snmp.internal.SnmpBinding] - SNMP: snmp not initialised - aborting request

So far I’ve tried/tested:

  • Theres is NOT a program running on this port, so port is not blocked
  • Doing a SNMPGET (using snmpget.exe) and I get the correct value so port 161 is working and device is ok.
  • Modifying the config file for snmp on openhab, setting port in 161 (I know that this port is open in windows and router).
  • I tried running via EXEC binding the command for smtpGET on the PAPER UI (I don’t know how to do it with the items files) and I get the temperature value… I just don’t know how to divide it by 10 to get a correct result.

So… mainly my question is:
Why is the SNMP Service not running? What I’m doing wrong?

Thank you!!!

Can you show your snmp.cfg file, please?
Are you sure you want to update your item every 100ms?

Hi Vincent, Thanks for you help!

Regarding the 100ms, I’ve tried multiple values just to see if something changes… it doesn’t work with 100, 1000 or 10.000

Here’s my config file (I’ve also tried with the defaults and with a port higher than 1000):

Listening Port (optional, defaults to ‘162’)


The SNMP community to listen to (optional, defaults to ‘public’)


The SNMP retry timeout (in milliseconds). Defaults to 1500.

Sets the number of milliseconds between retries.


The SNMP number of retries. Defaults to 0.

Sets the number of retries before aborting the request.


Thanks! Have a nice day.