SNMP Thing doesn't initialize after disabling

Hi everyone,

I have a problem with snmp binding (v2).
I have configured everything (thing, channels, items) with text files and it’s working as expected.

But after disabling the thing (UNINITIALIZED (DISABLED)) and enabling it again, the snmp:target thing stays uninitialized (UNINITIALIZED (HANDLER_MISSING_ERROR)). Doesn’t matter how often I try or if I do the disabling/enabling via PaperUI or rule. So it seems to be reproduce-able. All other snmp:targets continue to work properly.

Is this a known limitation? Even a intended behavior? Anybody ever seen the same? Any hint’s welcome :wink:

For reference:

  • same procedure works for other things/bindings, so it seems to be a snmpv2 issue
  • OS: Docker on Synology
  • OH version = 2.5.10


To answer my own question… just for reference…
Tried to deep dive into this issue today… but everything worked as expected. Did no update or so in between. So I can just guess that a restart I did some days ago fixed the problem.