[Solution] Unable to connect to WiFi after Hotspot configuration in OH 4.0.1. Comitup start error

Disable Comitup for fresh installation.
Failed to start comitup WiFi management.

OpenHab Image Version: 4.0.1
Hardware: Raspberry Pi 4
SD Card: 16GB

I want a fresh OpenHab 4 installation and burn the image on SD Card. I inserted SD Card in RPi 4 and started the system. OH exposed a Hotspot to configure the WiFi. However, after providing the correct details, after reboot, an error is thrown “Failed to start comitup WiFi management”. Initially, I thought that there was some error while entering the WiFi password and I burn the image again. However, I again experienced the same behavior for around 5 times on RPi4 and RPi 3b+. I tried searching the internet and realized that the issue is quite common with many users.

While searching the logs I figured that comitup was not able to find the NetworkManager service after WiFi configuration.

I changed the following lines in my first-boot.bash file:

  • Line # 88
if [[ "$hotspot" == "enable" ]] && ! [[ -x $(command -v  ) ]]; then


if [[ "$hotspot" == "enable1" ]] && ! [[ -x $(command -v  ) ]]; then

  • Line # 113
if [[ "$hotspot" == "enable" ]] && ! [[ -x $(command -v comitup) ]]; then


if [[ "$hotspot" == "enable1" ]] && ! [[ -x $(command -v comitup) ]]; then

Basically, I just changed the condition to always return false and do not start the comitup hotspot.

Thereafter, I supplied the wpa_supplicant.conf file in the SD card with the following details:


 ssid="<<Your WiFi SSID>>"
 psk="<<Your WiFi Password>>"

Make sure that you make all these changes before inserting the SD card to the RPi for the first time.

My RPi connects to the network in first attempt and all setup continues as usual without any issues.

The reason (and proper fix) is Network Manager not running because the service is disabled.
Not sure why, maybe this was changed in most recent Raspi OS.
Try systemctl enable --now NetworkManager.

Please flash a fresh image and try this:
Edit first-boot.bash from within Windoze before initial boot.
There’s a line to start NetworkManager, replace it with the command above.

Thank you for your reply. I will try with your solution once again and see if this works.
Earlier, when I was searching for this issue over internet I couldn’t find any proper solution and hence came up with my own :yum:

Thanks a lot for the help. It worked on my pi3+ as well. However I hope it get somehow fixed because I needed a long time to find this out.


it is fixed in recent openHABian.

Thanks a lot for the help. After I got the installation done I tried the two zwave binding with: ZWave Stick 800 Series Long Range DIY Hub, LR, USB, Z-Wave Plus v2

Both failed the z-wave binding found the stick but I could not get the network map nor any connection to a device. Is this fundamental an issue ? Should I usse the mmqt binding together with a installed z-wave system on the raspberry or can I provide something to help ?

That’s off topic. Please open a new thread if you are looking for general help.

Just for your information. I installed openhabian right now via raspberry pi imager onto a new SD card and I ran into the same error as OP.

With the enabling of the network manager service I got the system up and running. But maybe there is still an error somewhere?
Or does the raspberry pi imager not have the most recent version of openhabian?

+1 / same for me: Just downloaded the latest version of openHABian (as a test system) on my Raspi 3+, and ran into the same error.

Update: systemctl enable --now NetworkManager also solved it for me, but I can imagine that someone with no experience with Linux who just wants to get openHABian running will be pretty lost.

I’ve pushed the main (=development) branch over to openHAB (which is what you download by default).
Please try again anyone to have this problem.

question from such a beginner, how do I get this dev branch version where the network issue for new installations is fixed?

I have looked here but both versions were not changed the last days:
1.9beta (last change 21.11.23)
1.8b (last change 12.08.23)
(Releases · openhab/openhabian · GitHub)

In any case, your work is appreciated :)!


1.9beta still solves the issue!