[Solved] 1.9.0-Snapshot lost distribution/pom.xml, zip and deb files missing

I need a new binding for jeelink which is missing from official sources 1.9.0-SNAPSHOT and 1.8.x.
So I try to compile from sources. Target is a Raspi2 an Raspbian Jessie.

When I build the 1.9.0-SNAPSHOT (on Linux 64Bit, Java 7, Maven 3.3.9, Suse Leap) the distribution directory remains empty, no ZIP files, no DEB file. (First I tried with Java 8, then Java 7).

It seems to me that the last change on the distribution directory “Merge pull request #4199 from watou/squeeze-config” removed the pom.xml which is necessary, but I’m a beginner in OpenHAB and git.

How can I build OpenHAB 1.9 from sources with Maven and install the result on my Raspi2?

Greetings, Greenoid.

I learned just from

that this is the intented behaviour.

This is documented nowhere and leaves me with enhancing 1.8.3-SNAPSHOT with new binding but not with 1.9.0-SNAPSHOT, because I cannot move and install the result from my development laptop to the Raspi2 target at all. Should I mix 1.8.3 and 1.9.0 packages? I doubt this will work.

Please revert the decision or create some goal for maven like “mvn goal:build_zip_and_deb” that does the same as before on purpose and stating so.


I managed to merge the inofficial Jeelink binding into the 1.8.3-SNAPSHOT branch and it compiled, created the zip and deb files and I could install it on my Raspi2. It works. Great.