[SOLVED] [2.0.3] MapView doesn´t work

Hi there,

i just updated my iOS app to 2.0.3 and read the changelog to see that MapView is now supported.
So i killed the app, started it again and went to my MapView frame just to see … nothing!
Seems like there´s still a bug in the app or maybe in my environment.

I´m using Mapview for my iOS devices (Location from iCloud binding) and my car (Location from BMW Connected).
It works great in a browser with BasicUI, but not in the iOS app.

iCloud item

Location iPMichael_Location "Ort" <map> (iPhones, gPersist) {channel="icloud:device:openHAB:iPMichael:location"}


	Text item=fbMichael
		Mapview item=iPMichael_Location

Is this a bug in the iOS app or my configuration?
As it´s working in browsers with BasicUI i think it´s still a bug :slight_smile:

Edit: Some more informations
Hardware: Raspberry Pi 3 B+
OS: Raspbian 9 (stretch) with openhabian
oH: 2.4.0-1 (Release Build)

Hardware: iPhone Xs
OS: iOS 12.1.1 (16C50)


Read earlier that some else was having a problem with iOS and needed to change the sitemap settings “Icon Format” in PaperUI to bitmap and install ClassicUI. Why ClassicUI, I have no idea but it worked for them.

I‘m currently still using the bitmap mode with .png graphics instead of vectore mode with .svg graphics.
The ClassicUI should be is installed but i‘ll check that again in version 2.4.0

The iOS app is running without errors and i just wanted to check the new feature for MapView compability.

I get the same results.
I just downloaded the lastest app yesterday.
For me where I’m using Webview item in the sitemap it’s hidden in iOS

@digitaldan do you have any idea why the new feature isn´t working?
Or could we help you with logs or other actions?

kind regards

That’s working for me:

Mapview item=location_item height=5 icon="place"

I think, the height-parameter is the bottom line.

1 Like

Thanks Christoph!
I never used this parameter as the BasicUI automatically used an height :slight_smile:

@Phuong please try if the height=5 is working for you also.

I´ve made a PR to correct the readme of the iCloud binding.

kind regards

Yeah I did add the height parameter now and it works now!
Great finding!
Thanks :slight_smile:

1 Like