[Solved] 2/10/2017 ZWave Binding Broke ALL Switch Things

Try now…

That worked!
A ‘apt upgrade’ of openhab2 caused the binding to be updated and now all my lights are working again.


1 Like

Thanks :slight_smile:

I can also confirm that the update fixes the switches on my system as well. Thanks for all your support.

Works for me, I updated the original post with the solution, thanks for your help.

how do i update to the last binding i am using openhasbian and i dont work whit uninstall and wait 30 seconds and instal it again

It depends:

If your are on the stable release: uninstall the zwave binding, download the snapshot zwave binding, add the .jar to your addons folder.
You also could upgrade openHABian from stable to snapshot release.

If your are on a snapshot release: uninstall binding, wait, install binding.

wher do i find the snapshot zwave binding


now i copy the org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar into /usr/share/openhab2/addons what do i do now in the paperUI i dont see the binding

Log into your karaf console, do a bundle:list and see if the binding is active:

204 | Active | 80 | | ZWave Binding

244 | Installed | 80 | | ZWave Binding

is say installed but ther is not one Active | 80||ZWave Binding most ther be that

Okay, installed, but not ACTIVE.

Do a bundle:start org.openhab.binding.zwave

i get this error

Error executing command: Error executing command on bundles:
Error starting bundle 244: Could not resolve module: org.openhab.binding.zwave [244]
Unresolved requirement: Import-Package: gnu.io

Okay, I have no idea …

Making a snapshot binding work on a stable release is not a good idea.

If you want snapshot features, you should use the snapshot runtime.

okey tanks for your help i will try and if sombody els can help

You need to install the serial binding.

I tried the snapshot today and I’m getting the same thing. Reinstalled the binding and everything else in this thread but nothing.

205 | Active | 80 | | ZWave Binding

2017-05-04 20:11:29.246 [WARN ] [.core.thing.binding.BaseThingHandler] - Error while applying configuration changes: 'IllegalStateException: Timer already cancelled.' - reverting configuration changes on thing 'zwave:device:500632da:node2'.
2017-05-04 20:11:29.261 [ERROR] [ome.io.rest.core.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:500632da:node2/config' for thing 'zwave:device:500632da:node2': Timer already cancelled.