[SOLVED] A new User stuck for days with the same problem(s)

Good Day,
I am a new user and been hitting my head against the wall since last Wednesday. Maybe someone can point me in the right direction or to the right post/documentation. So far I’ve seen my problem on your forums, but it does not apply to my setup so the suggested solutions do not apply.

Here is my setup
PC; Homebrew, i7 7700, 32 GB RAM, 255GB SSD, 1000 wired network.
OS; Win10 64

Software installed; SD Card formatter, balenaEtcher, ipscan-win32-3.5.5.exe, Putty

I am trying to install on a Raspberry PI, 3 B+ and using image; openhabianpi-raspbian-201804031720-gitdba76f6-crc9e93c3eb.img.xz

I believe I am Flashing the image correctly because Etcher is completing with 1 successfully

I generally wait over night for the first install/boot.

I have tried multiple SSD cards, a couple of 32GB (Verbatim & ADATA) and now I am trying a 16GB SanDisk (Brand new out of the package). I was thinking maybe I had a bad micro SD card. ?But 3 of them? The SanDisk does format and Flash faster, understandably because it is only 16GB.

Here is where I get stopped;
The next morning when I bring up Firefox, and goto http://openhabianpi:8080/, I get Unable to Connect. Chrome responds ERR_CONNECTION_REFUSED.

When I attempt to connect via PuTTY, User: openhabian/Password: openhabian
I get Access Denied

Folks, I am now out of idea’s and any help would be appreciated for a newbee. This is my second post and the first since I began this quest of Raspberry PI and openHab. I ask about openHAB capabilities in my first post.


It’s hard to say what the problem is. But did you try connecting a monitor and keyboard directly to the raspberry pi to see what actually is happening?

Did you unzip the image before flashing ???

Hi hilbrand,
Thanks for responding. Well, I have connected an HDMI wire and I am currently switching my monitor back and forth. All seems to look good (i.e. I’m not seeing any glaring Errs that would stop the process).
Actually, that is how I learned the First Time Startup had completed, by watching that process.
I ordered a USB keyboard, but it won’t be here until Monday, maybe between the Monitor and Keyboard I can get somewhere.
Thx Bill

Yes Sir, I did unzip the file. I had hoped when I showed the image file in my description the .img.xz extension was visable.

Do you know the IP address;

Thanks for responding ngalfas, Yes the ip is

Maybe this will help ping work without a problem

Is that a typo? You’re using the wrong password. (I think)

Password authentication Password : The default username/ password is openhab :habopen, so enter habopen at the password prompt.

Can you confirm you’re using putty on the correct port? 8101 iirc


The Pi 3 B+ are very, very(!) picky in terms of the power supply. I cannot stress this enough. Many “good” 2+ Amps power adapters like e.g. the Apple iPad power adapter are not powerful enough for the 3 B+. I have had tons of crashes and reboots, not only with openHABian but other installations as well. Most of the time the Pi seems to start fine (at first). But as soon as there is load it might suddenly freeze or crash at random.

Instead of crashes or freezes I have also seen weird error messages that made it seem like a completely unrelated problem had occurred. Like access problems or checksum errors.

If you are not aware of the issue, checking your power supply is worth a try. I didn’t believe it as well at first until I got a bloody nose… :slight_smile:

I am using one of these: Anker Desktop Chargers (no affiliation!) which I have found to be working well with the Pi 3 B+.


Thanks for the reply Crispin
I found the userid and password from a youtube video by BK Hobby. His first video covered the install and setup. In the video he uses UserID=openhabian and password openhabian. I just double checked the video to verify to make sure I did not do something dumb and watched as he used openhabian / openhabian. It worked for him right before my eyes.

Maybe this is an old Video, has the default Userid/Password changed over time?

Anyway, trying to follow any suggestions, I just tried UserID=openhab and password=habopen. I think that is what you were suggesting. Again, Access Denied.

Next I changed the PuTTY port to 8101(from the default of 22). Using 8101, I never even got “Login as:” The screen just stayed blank.

Thanks but no joy so far.

Thanks jewesta,
I believe I have the correct power supply. I purchased my Raspberry PI as a kit off of Amazon. It came with the Raspberry PI, 2 heat sinks, a case, and a 2.5A power cube.

Thx (I really Appreciate everyone’s input)

Try flash normal raspbian on a new sd card and boot that. Once you have that vanilla running login with pi / raspberry and run sudo apt-get install openhab2. Quite simple :slight_smile:

Some form of Java is required too before OH will run, if you install with apt-get.

@bmachia can you confirm SSH is running on the Pi? ‘sudo systemctl status sshd.service’ can report the status.

Have you also tried telneting to the SSH port on the Pi from the remote machine? This will also verify if that port is even responding/not blocked?

Have you also reviewed the various logs in /var/log/ that might provide some additional info on the issues?

A few comments here have steered you in the wrong direction. user/pass is both “openhabian” and the habopen password is for reaching the Karaf console not what the user is currently trying to do. Openhabian installs Java for you, you do not need to do it.

Port 22 is correct with putty. Best to follow the steps here

Some ideas are:

  1. Try using the IP and dont use openhabianpi, sometimes routers dont resolve hostnames correctly.
  2. Try installing again from scratch a few days later, if a server is down the installation will fail.
  3. I have seen an issue recently/currently where after a linux update it broke SSH connectivity, I have not bothered to look in depth as to why yet. It is possible you are doing everything right and it is simply a linux bug which will be solved soon as is nothing to do with Openhab.

Thank You to Everyone!!!

I just pulled an All-Nighter and got this thing working. I had thought I grew out of All-Nighter’s 30 years ago when I graduated college. But when needed, you do what you want to do.

Anyway, using the monitor, as suggested by hilbrand, I found I had two errors stopping my progress. They were

But somehow, the installation script kept running even after these two error.

What bothered me next, and maybe someone can tell me why , was a line in the script that said; “Changing default username and password”. I wonder if this change was the reason, I kept getting Access Denied from PuTTY?

Next, I took Crispin idea’s. I separated the installation. First Raspberry PI and then installed openHABian. That’s when I started to get somewhere. After two tries, I had Raspberry PI, running, and it only took one attempt to get openhabian up.

After this two-step installation, I could see; http://openhabianpi:8080 and then PuTTY had no problems logging on.

Now HONESTLY, I cannot prove the two-step process was the solution. But I can say it worked I was able to get farther than I had since I started this Last Wednesday.

I have gone through all the steps in BK Hobby’s initial “YouTube” video, next onto video 2.

  • No more Access Denied.
  • openhabian/openhabian now logon’s on without Deniall!
  • Sudo openhabian-config ran just as described.
    • Logviewer is installed
    • Mosquito is now installed
    • I have moved the OS to the attached 32GB USB memory

I finally returned to the browser at http://openhabianpi:8080 and installed DEMO. I’m checking out the Tiles, Basic UI, and Paper UI now.

AGAIN, Thanks for everyone’s Assistance! It is really nice to have a Support System/Group like you folks!

Happy Saint Patty’s Day


now you 're getting ready, start implementing your SD card backup method :slight_smile:
this is equally important when using SD storage.