[Solved] After migration to v1.8 group item can't be opened anymore

Hi Forum

I just migrated to v1.8. Basically it’s working but at one place I see a bug:

  • left picture, click on “Alle Lichter” is supposed to open a group with all lights
  • right picture: group “Alle Lichter” is not opened, insted the title of the page is messed up; lights via group can not be reached/steered anymore

Does anyone else see the same behavior? Any solution available?

Thanks & Regards

P.S: I just tested again in v1.7 - there the group is still working fine…

I am seeing a similar thing but it seems to be related to my switch. After “turning on” switch it goes blank similar to yours above at bottom of the screen shot. Then after about 10 seconds it becomes visible again and everything appears to be normal, ie i can turn off the switch move about the configuration until I turn on another switch then the same behavior occurs.

I even can’t get to the sub-page where the switches of all lights of the group “Alle Lichter” are.

I tried with clicking on the above mentioned item and wait. Now, 2 hours later, still nothing happend.

A restart of OH didn’t change anything.

Are they sliders or switches?

In my instance they are switches. I probably should open a new thread and not hijack this one.

Odd, looks like the slider issue, what do you see on Chrome console (Ctrl + Shift + i)?

Just to clarify. This is a switch for a hue bulb. That when I turn on “exposes” color wheel and two sliders one for temp and the other for brightness. Looking at the console Chrome console I see these two entries each time I “turn” on the light.

TypeError: Cannot set property ‘innerHTML’ of undefined(…)__callback @ Logic.min.js:1c @ Logic.min.js:1
TypeError: Cannot set property ‘innerHTML’ of undefined(…)__callback @ Logic.min.js:1c @ Logic.min.js:1

Then a few seconds after the second entry the “switch” will reappear

Great, its the same issue, try adding [%s %%] to the end of the name in your items file such as:

Dimmer	Water_Room_Light		"Water Room Lights [%s %%]"				(Water_Room, Light)	{insteonplm="24.92.DA:F00.00.01#dimmer"}

That may fix your issue, at least it fixes the Logic.min.js issue with dimmer sliders.

Thanks for your efforts but did not change the behavior. My Items are:
Switch Toggle_1 “bonus room right” (wg_HueSwitch) {hue=“1”}
Dimmer Dimm_1 “bonus room right [%s %%]” (WhiteDimmer) {hue=“1;brightness;30”}
Dimmer CT_Dimm_1 “bonus room right [%s %%]” (CTDimmer) {hue=“1;colorTemperature;30”}

and it made no difference. I did stop and start openhab just to make sure I got a clean “load”. Additionally, I tried adding it to the Color picker and it still made no difference.
Color Color_1 “right [%s %%]” (wg_Colorize) {hue=“1”}

I removed it from color just in case it was affecting the behavior.

OK. I have it working now. In the sitemap I was using a label for the sliders that apparently was “over writing” the “bonus room right [%s %%]” labels in the sitemap. When I removed the label from the sitemap the behavior was as expected.

Just so it’s clear, this was a bug in 1.8.0 that is fixed in 1.8.1. See this thread and this PR.

In my case: switches only.

Unfortunately this doesn’t resolve my issue. My sitemap looks like that:

Group  	item=gLights
Group	item=gSD

For gLights I have the described issue, for gSD (power supplies) it is working fine. As one can see, there is no additional label in the sitemap - I’ve set the label in the item file.

Group gLights contains switches and dimmers and a sub-group for switching various Hue bulbs together.
As I said: in v1.7.1 it was working fine, after upgrade to v1.8 this group (and only this group) is not working anymore.

What does your .items look like? Do you have [%s %%] in the labels?

No, only one group switch with [(%d)]

Group:Switch:OR(ON, OFF) gLights "Alle Lichter [(%d)]"

Ok, you going to need to change your items so that you have a description with [%s %%] in them, they are blank now so your hitting a bug.

Just changed it according to your advise. Now I can access the group again and reach every single switch. Thank you so far.

But now there are many not needed %-signs displayed. Are they necissarily needed due to the workaround?

I think you can change "[%s %%]" to "[%s]" and the workaround will still work. Will be fixed in 1.8.1.

Looks better now. Thank you very much.

I’m really looking forward for v1.8.1.

1 Like