[SOLVED] After restore from 2.3 all Add-Ons are empty

Platform information:

  • Hardware: Raspberry PI3
  • OS: Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux
  • Java™ SE Runtime Environment (build 1.8.0_191-b12)
  • openHAB version: 2.4.0

I had several issues after upgrading to 2.4, so I installed my Raspberry new. I started OH 2.4, all works fine.
But after restoring my backup from OH 2.3 all Add-Ons are empty. Before doing the restore all lists are filled, so I could see all the Addons.


openhab1.log (811.1 KB)

openhab2.txt (898.2 KB)

At the moment for me is really unclear, what I can do.
Any ideas?



What exactly did you restore? The whole “openhab”-folder or only the “conf”-folder?

Did you create an addon.cfg file in OH 2.3.0? If so, did you restore it, too?

@ Celaeno1Alex

I did the backup with openhab-cli backup and the restored it with openhab-cli restore, so the whole openhab folder should be restored.

The addons.cfg file exists with the default entries. I never done any changes at OH2.3 at this file.

This is the openhab.log entry of the issue:

2018-12-29 08:56:54.447 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': No matching features for openhab-package-standard/0.0.0
2018-12-29 08:56:54.554 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-http1, openhab-voice-voicerss, openhab-binding-exec, openhab-binding-yahooweather, openhab-binding-fritzbox1, openhab-binding-airquality, openhab-misc-openhabcloud, openhab-binding-avmfritz, openhab-transformation-javascript, openhab-ui-habpanel, openhab-transformation-regex, openhab-binding-denonmarantz, openhab-transformation-jsonpath, openhab-binding-zwave, openhab-action-telegram, openhab-transformation-map, openhab-binding-lgwebos, openhab-action-mail, openhab-binding-kodi, openhab-binding-systeminfo, openhab-ui-paper, openhab-binding-wol1': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=system; type=karaf.feature; version="[4.1.5,4.1.5]"; filter:="(&(osgi.identity=system)(type=karaf.feature)(version>=4.1.5)(version<=4.1.5))"


There is a similar topic (same error like you) here, please read it carefully.

There are 2 solutions inside! Maybe this will help you, too.

Solution1 (helped to solve the error)

Solution2 (helped to solve further errors)

1 Like