[Solved] After the update, MQTT stopped working

mqtt
Tags: #<Tag:0x00007f1e5759b178>
(Dmitriy) #1

Hi!

After the update, mqtt stopped working. Installed the latest version of openhabian, did not help. The message is stuck in the system. Through MQTT.fx messages go without problems.

Here are my settings.

home.sitemap:

sitemap demo label="Main menu" {
	Frame label="Hallway" {
		Text icon="corridor" {
			Frame {
				Switch item=SwitchHallway1 icon="wallswitch" mappings=[ON="On", OFF="off"]
			}
		}
	}
}

mqtt.cfg :

ohmqtt.url=tcp://localhost:1883

switch.tems:

Switch SwitchHallway1 “Hallway” (Lights) {mqtt=">[ohmqtt:hall/switch:command:ON:1814700],>[ohmqtt:hall/switch:command:OFF:1814701]"}

Please tell me what could be the problem?

0 Likes

(CM6.5 H102) #2

Looks like your mqtt items are the 1.x mqtt binding version. Did you turn on legacy bindings in PaperUI and install the 1.x mqtt binding after the update?

0 Likes

(Dmitriy) #3

I have only this addon available.

MQTT Binding

binding-mqtt - 2.4.0

0 Likes

(CM6.5 H102) #4

In PaperUI you need to enable legacy bindings it’s found in Configuration > System > Addon Management. Refresh the page and after that you will see the 1.x mqtt binding and can then install it.

Make sure to click Save after enabling it.

1 Like

(Maurits) #5

I had a similar thing where after the last upgrade to 2.5.0 Legacy bindings was switched off instead of on.

0 Likes

(CM6.5 H102) #6

Yep, legacy bindings turned off seems to be the default setting when upgrading.

0 Likes

(Dmitriy) #7

Thanks!!!

I went to remake on version 2 of mqtt.

0 Likes

(CM6.5 H102) #8

You want to use the 2.x mqtt binding? If so you might want to upgrade to 2.5 snapshot to avoid a bug when editing text files and needing to restart OH each time.

1 Like