[SOLVED] AirQuality "dead"?

Hi all,
I’m struggling with the air-quality binding which retrieves the data from aqicn.org. (using Version 3.2.0 stable). I use it since a while and all was working, but just yesterday I recognized the values are set to NULL. So i started to investigate and understood from the binding documentation, that the “Thing” has changed. So i updated my file according the docu, without success.

I ended up reinstalling the Binding, also without success and recreating the thing/item files. Also tried to set the Binding to DEBUG or even TRACE - but no… it stays silent.

My things-file (permissions are correct):

Bridge airquality:aqi:main "AQI Bridge" [ apiKey="xxxxxxx" ] {
 station AQI_Vienna15 "AQI Home Vienna 15" [ location="48.205,16.30975", stationId="2850", refresh=60 ]

The related item file:

Group AirQuality <flow>

Number   Aqi_Level           "Air Quality Index" <flow> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:aqi#index" }
Number   Aqi_Pm25            "PM\u2082\u2085 Level" <line> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:pm25#value" }
Number   Aqi_Pm10            "PM\u2081\u2080 Level" <line> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:pm10#value" }
Number   Aqi_O3              "O\u2083 Level" <line> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:o3#value" }
Number   Aqi_No2             "NO\u2082 Level" <line> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:no2#value" }
Number   Aqi_Co              "CO Level" <line> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:co#value" }
Number   Aqi_So2             "SO\u2082 Level" <line> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:so2#value" }

DateTime Aqi_ObservationTime "Time of observation [%1$tH:%1$tM]" <clock> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:aqi#timestamp" }

Number:Temperature  Aqi_Temperature     "Temperature" <temperature> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:weather#temperature" }
Number:Pressure     Aqi_Pressure        "Pressure" <pressure> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15:weather#pressure" }
Number:Dimensionless Aqi_Humidity        "Humidity" <humidity> (AirQuality) { channel=" airquality:station:main:AQI_Vienna15weather#humidity" }

Any idea what got wrong here?

Thank you!


Do you have any indication that the changed .things file is used ( log entries or updated channels in MainUI)?

Just FYI, i also noticed the AQI biding not working and saw that there are now 2 Things needed (?).
One to define the token (bridge on screenshot) etc. which has no channels, the other (station) to define the actual measuring station which then also has channel and items.
I use the UI though.

Yes I can confirm, that the file is used. I see the related message about the file being loaded. And for test reasons I added a syntax error to see if it’s rejected too. Both true. So the file is definitely used.

Thanks to your hint, @chrismast, I found it.

The issue was a simple typo/misreading of the documentation. I wrote


instead of


That was all the secret! Thanks guys for the help

Such errors won’t happen when using the UI only for setup!

1 Like

You are totally right. And my preferred way doing it is by files instead of the UI. So yes, I may make a mistake again somewhere, sometime. And yes I may need another pair of eyes again to help me find the issue.

Sure, but using files allows you to automate the generation (and therefore sanity checking) from a canonical source of truth, to keep everything properly in git for tracking purposes, and most importantly ensure a consistent configuration, so while I was bit by this exact same thing, I, like @NightDragon much prefer files to clicking around in a browser.