[SOLVED] Alexa does not discover any item - caused by a malicious ip binding


on my openHAB 2.5.5 installation on Windows 7 I’m currently trying to allow Alexa to discover my items. I first had the Hue emulation installed, which worked perfectly after switching openHAB to port 80. But as the support for more specific categories e.g temperature is very limited in the hue emulation I want to use the Alexa Skill described at https://www.openhab.org/docs/ecosystem/alexa/ to discover my items.

Therefore I also installed the openhab Cloud connector and connected it to myopenhab.org. myopenhab.org also tells me that the status is “Online”. Besides that I installed the mentioned Alexa Skill in my Alexa environment (two Echo Dots v2 and one Echo Dot v3) and linked that as well to myopenhab.org.

After that I added the required metadata “Switchable” as well as the tag (seems like this changed over the different alexa skill versions, to be safe I added both) to the item.

openhab> smarthome:metadata list BueroSchalter
Metadata [key=alexa:BueroSchalter, value=Switchable, configuration=[]]
openhab> smarthome:items list
BueroSchalter (Type=SwitchItem, State=OFF, Label=Büro, Category=Light, Tags=[Switchable])

But when I now start the discover process in Alexa it can’t find any devices.

After double-checking everything, the only weird thing I could find is that when I visit https://home.myopenhab.org/start/index instead of showing my dashboard I just get following error message: openHAB connection error: Connection refused: no further information
But I don’t know if that’s at all required for the Alexa skill, also accessing it via the internal ip directly works.

I checked a lot of different topics in here, but none of the mentioned solutions, e.g. deactivating the hue skill (which I did) worked for me. Actually I’m not sure i Alexa at all finds the openhab instance, is there any way to verify this?

The logs don’t show any obvious related error.

It looks like you are having or better you system is having a problem to connect to the openHAB cloud.
Reading the docs about the Alexa Skill you should have stumbled upon: The skill connects your openHAB setup through the [myopenHAB.org](http://myopenhab.org/) cloud service to Amazon Alexa.
In other words the cloud connection is needed.

Thanks, you’re right. I was playing around on the weekend with the ip binding as I’ve running Phoscon and openHAB on the same instance, which leads to some conflicts, therefore I bound only the static ip address to openHAB, but it didn’t accept connections anymore on localhost.

This is fixed now, my.openhab.org works, as well as the discovery of Alexa was successful.

Thanks for pointing me in the right direction!