[SOLVED] [Alexa] Severe openHAB connection problems after re-installing Alexa skill

alexa
alexa-openhab
Tags: #<Tag:0x00007f51dc322820> #<Tag:0x00007f51dc3226e0>

(Metin) #1

My openHAB and Alex have been good friends, and I was able to control all my devices over Alexa amazingly well. Then, I decided to try out the new v3 Alexa skill, and got into trouble.

After having installed the new skill, Alexa discovered all my devices, but fails to control most of my devices. For example, when instructed to increase the temperature in room name, Alexa replies “the skill connected with room name is not activated. Please active the skill to control this device” or “I could not find a device or device group named room name in your profile” or sometimes just “Device does not respond” (all message freely translated from German). Even more confusing, occasionally devices do work, then they stop working again.

When I try to check the devices in the Alex app, selecting the device hangs on “waiting for openHAB”. However, when logging in to myopenhab.org, my openHAB instance is reported to be online, and I can connect to its UI from there.

My logical assumption was a problem with the v3 Alexa skill. So I reverted back to the public release version that worked flawlessly before, but now I’m having the same trouble with it.

I did not change anything in the Item definitions, as I know they worked perfectly.

Is there a way to completely reset the connection between Alexa and openHAB, other than deactivating the skill (which I have done twice now to no avail)? Any other ideas?


(Metin) #2

I’ve been able to get all devices back to work with Alexa by

  • Removing (deactivating) the openHAB skill
  • Explicitly deleting all devices from Alexa
  • Explicitly removing all groups from Alexa
  • Restarting openHAB (although that’s probably not necessary)
  • Activating the openHAB skill and reconnecting it to myopenhab.org
  • Rediscovering all devices
  • Setting devices and groups from the ground up

After that, I was able to control the devices like before.

Tip: It’s obviously not possible to remove all devices in one go using the Alex app. To do so, go to https://alexa.amazon.com, select Smart Home > Devices, and scroll down to the bottom of the page to find a button to remove all devices.