[SOLVED] Alexa TTS via http

Dear all,

I am quite new in the world of openHAB. This is my setup:

What I’ve done so far:

  • Installation of openHAB 2.3 on my Synology Diskstation in the /public/openHAB/ folder.
  • Connecting my Echos with the Amazon Echo Steuerung Binding
  • All working on the PaperUI.

My aim is to open a link externally like http://openhabserver:8080/AlexaLivingroom/say='This is a test’ and the Echo in my living room says the word “This is a test”. In the Paper UI I achieved the possibility to make the TTS possibile with the “Say” channel, but from externally I am too dumb… :wink:

I already installed the http binding because I assume this will be the tool I need for it, but as this has no GUI configuration possibility I am totally lost by this last step.

Perhaps anybody can help me with this? Sorry to say, but I think I would need a step by step assistance on that :wink:

Kind regard,


If you have the ClassicUI installed (no need for HTTP binding for this), then you can update the state of the item linked to the textToSpeech channel using…

http://[openhab server]:8080/classicui/CMD?[item linked to textToSpeech channel]=This%20is%20a%20test

Some browsers will replace spaces with %20 for you, so try without the %20s and see if it works for you. There may be better options… what are you trying to achieve?

Also, it would be best to move your post to another category, since your asking a question and not posting a tutorial. :wink:

Hi Scott!

Thanks alot for your reply!

I tried now that one: http://192.168.0.XXX:8080/classicui/CMD?EchoWohnzimmer_Speak=Das%20ist%20ein%20Test

But there is no reaction, no answer from the browser (no 404 or so) and Alexa stays silent. On /public/openHAB/userdata/jsondb the org.eclipse.smarthome.core.items.Item.json contains the following:

“EchoWohnzimmer_Speak”: {
“class”: “org.eclipse.smarthome.core.items.ManagedItemProvider$PersistedItem”,
“value”: {
“groupNames”: [],
“itemType”: “String”,
“label”: “Speak”

Do you have any idea where my mistake is?

About moving this topic to another category, yes, please… I just didn’t know where to post it.



This looks good… https://community.openhab.org/c/add-ons/text-to-speech (you’ll need to move it)

If you didn’t have ClassicUI installed, you’d get a 404, so that’s not it. It’s normal that nothing is displayed. But it also doesn’t display anything if you mistype the item name, so make sure you have it typed right (it’s case sensitive)… maybe missing an underscore? Does the state of the item change in one of the UIs or in the event.log? You could also check it’s state in the Karaf console with smarthome:status EchoWohnzimmer_Speak

Thanks for the hint with the Log!

By reading the log when successfully making Alexa talk via PaperUI Control, I found out that the item name had to be different. Now it works :slight_smile:

1 Like

Hi Thilo
I’d really like to do this too, i’m totally new to OpenHab but have it all up and running with Alexa etc. I just cant seem to work out how to make her speak using the HTTP like you suggest

What command did you use to get Alexa to speak using HTTP ?
Can you show me a sample of what you do please ?