[SOLVED] Amazon Echo Binding 2.4


Openhab noob here.

I’ve been trying to get my Amazon Echos working for multiroom music etc for habpanel but have had trouble with the standard binding install on paperUI (2.3), coming up with: “��Yks�ȱ��_A�R4p1�D9{�&4f�!'���}��l%�V5@” etc…

I read on the another post that the 2.3 binding is not working and that I should install the 2.4 binding instead. I am running openhabianpi and connecting with ssh on mac terminal.

I attempted to install the .jar of the amazon echo control (2.4) binding by using the command in the terminal ssh window:
" /usr/share/openhab2/addons $ sudo wget https://www.dropbox.com/s/g3no6ml4cmlh3wx/org.openhab.binding.amazonechocontrol_2.4.0.201812161428.jar?dl=0"

It seemed to save to the folder okay as far as my limited understanding can tell.

I am still having no luck configuring the Amazon Account Thing - when I try to configure using myhab:8080/amazonechocontrol I get the same thing as I did with the 2.3 binding.

I’m not very code literate and I’m not sure if the 2.4 binding is installed correctly, even if it is I do not know how to configure it outside of PaperUI…

If anyone out there can help me figure out where I’ve gone wrong and how I can resolve this it would be much appreciated!


Check the permissions for the jar file and make sure you have uninstalled the binding via PaperUI before adding the jar file.

Thanks for the quick response.

I have checked this as you suggested and got the output below.
I noticed I had the old Amazon Account Thing still on PaperUI - I wonder whether this would have disrupted something? If so any idea what I would need to put in the ssh terminal to uninstall the file so I can reinstall it?

The jar file is owned by root, needs to be openhab. Use sudo chown openhab org.openha.binding.amazonchontol_2.4.0.201812161428.jar check for typo;s in the file name, it’s a bit hard to read.:wink:

Thank you so much H102! :heart_eyes:

Managed to get to this bit so fingers crossed I can figure the rest out. Seems it was just the permissions.

Yep, just a permission issue.:wink: Glad you got it working.:+1:

If you would, please mark the topic as solved by clicking the square box (lower right corner) on the post that provided the solution. Also edit the title to start with [Solved] this will help other with similar issues to find a quick solution.