[SOLVED] Android App do not show me Sitemap Anymore, show me list of Thing

Hi,
since a couple of days, my OpenHab App, do not show me my sitemap anymore, but show me a full list of the things i have on my system but I do not have my sitemap anymore.

Thanks in advance for help
Kindly Regards
Marco

Hey Marco,
this is the default sitemap that is only shown if no other sitemap is found on the server. This can have two causes:

  1. You have renamed your sitemap to _default. Just rename it to anything else than _default.
  2. A syntax issue caused the server not loading your sitemap anymore. Please check your server log for more details.

Hi @mueller-ma,
very strange thing. I have no error in my sitemaps and they are available via web interface. Their name is different than _default.
I restarted OpenHab service on my debian box, and sitemap back working to the app.

Thanks for answer.
Kindly regards

Marco

Interessting. If it happens again, can you post the output of http://openhab/rest/sitemaps?

@mueller-ma
I will. But from web interface on PC my sitemaps works fine, only on mobile app are not shown.

Marco

This might be a rest api issue. Basic UI and Classic UI don’t use them.

Great, net time I will grab output you suggest and update this post.
regards

Marco

Hi @mueller-ma,
just happened again. Here is the results for http://openhab/rest/sitemaps

[{"name":"_default","label":"Home","link":"http://192.168.1.80:8080/rest/sitemaps/_default","homepage":{"link":"http://192.168.1.80:8080/rest/sitemaps/_default/_default","leaf":false,"timeout":false,"widgets":[]}}]

Kindly regards

Marco

As you can see the server does only provide the default sitemap and none of your custom ones. Therefore this is a server issue.
At the same time the custom sitemaps are available in basic ui?

Hi @mueller-ma,
answer is yes.

Marco

Hey. I found a solution for a similar problem. It was pretty simple solution by turning on “Show all Sitemaps in side menu”. I had the same issue like you had - sitemaps were in the app and then disappeared and only default sitemap stayed. But by this switch all works fine.

Btw. don’t ask me why the it disappeared. I don’t know, that’s the weirdest thing on this issue cause it worked, then stopped even I don’t remember that I switched of mentioned value.

1 Like

You probably don’t remember turning it off, because the switch was introduced by the latest version and is off by default.
It’s mentioned in the changelog on GitHub and Play Store, though: https://github.com/openhab/openhab-android/releases/tag/2.11.0-release
Please see https://github.com/openhab/openhab-android/issues/392 for the discussion about this switch.

Thanks! It makes sense now :slight_smile: