[SOLVED] Android APP stopped working remotly

Tags: #<Tag:0x00007f61737692c0> #<Tag:0x00007f6173769130> #<Tag:0x00007f6173769040>

My android app has suddenly stopped working remotly. I have not done any changes of the settings in the app before this happened.
I get the following message on my phone:
“Authentication failed. Pleas check the username and password respectively the provided SSL client certificate (HTTP response cod 401)”.
My remote settings:
URL= https://myopenhab.org:443. Have tried without :443 and got the same message.
Username= my mail address
Password= ****

Encryption:
SSL client certificate: None
Ignore SSL certificate: Box is checked.
Ignore SSL hostname: Box unchecked.

Anyone who can help me?

I had issues connecting to myopenhab this morning (Central Europe), but that was caused by the Server (see Status Page). I had to restart OH in order to reestablish the connection.

This did not help me.

I forgot to say in my 1st post that I have an Rpi 3B with a 16 GB SD card on which I installed openhabian.
OpenHAB is 2.3.0-1 Release Build and I have uppgrade system to the newest version in openhabian-config.
The system is running without any problem. The Rpi is connected by Ethernet.
In myopenhab.org it says that openHAB is not online. Items, Eventlog and Notifications are usually updated.
I get Push messages and e-mail at events. On my phone I have Android 8.0.
Long time ago I renamed my local host name from “openhabianpi” to “Guard1”, can this have any impact?

I’m sorry, but I have no clue why your OH instance went offline on myopenhab.org
The change of the hostname shouldn’t be a factor.
Rechecking the secret and uuid would be a point to check (if somehow they got changed on your system [SD-Card failure? as a wild guess])

Have previously checked the uuid and registered the secret again.
openhab.org now says that I’m online so I assume that uuid and secret are ok.
Have tried another SD card with the same result.
How to check the “provided SSL cliet certificate” which say’s in the error message?

This means that myopenhab.org rejects the request, because your username or password is wrong. Don’t worry about the ssl client cert, AFAIK you cannot use it when using myopenhab.org.
Double check if your username and password are correctly set.

Port 443 is default for https, so no need to add it.

I recommend to uncheck this one. It’s removed in version 2.3.0, but due to a major bug, 2.3.0 isn’t shipped via the play store yet.

@mueller-ma Thanks for your help!
I did all of your suggestions yesterday but received the same error message.
Today, I entered the username and password in the app again and now it works.
Even my wife’s phone works now without making any changes to her app ???
I’m happy it works again though, the app is a bit slower now than before.
Another thing, I have allways got the following [WARN] when I exit the app or I change sitemap:
“2018-10-29 13:49:47.879 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 7227002 failed: null”
Is this something you can explain?

Do you also see this error when accessing the sitemap locally?

No, only remotly.

Ok, in this case I don’t have a clue.

Thanks, do you think there is any point in opening a new topic about this?

I’d recommend to search for issues in the openhab-cloud repo on Github if you use Github. If not, a topic here is also fine.

Here is what I experienced with version 2.8.0 of the app on various brand new phones on Android 9 (Pie):

  1. I enter correct settings for the local connection
  2. I enter correct settings for the remote connection
  3. I connect to my server locally and accept the SSL certificate
  4. I can’t connect to my server remotely if I connected locally previously because the app never prompts me to accept the SSL certificate

I could fix that by force-stopping the app and connect remotely again. After force-stopping, the app does prompt to accept the SSL certificate for the remote connection and it works flawlessly afterwards.