[solved] Bad Message 431 - no acces to openhab container


I am running OH2 for month without issues in a Docker container.

Openhab is on port 8060 and not exposed to internet so no rev proxy is in between.

If I am accessing (as usual) I am receiving this:

Bad Message 431

reason: Request Header Fields Too Large

In openhab log I am finding this:

[WARN ] [org.eclipse.jetty.http.HttpParser ] - Header is too large 8193>8192

Any ideas?

Try clearing the cache and restarting OH.

I did as described here:

I restarted only container, the complete Server and I rebuild the container too …

Also clear the browser cache. The actual error is I think is saying that the HTTP header that your browser is sending in your request is too large.

I deleted the firefox cache but error message still apears.

I tried it with microsoft edge … working …
I hate it!!! what es should I delete :slight_smile:

This is caused by a ‘bad’ cookie. So clear browser cache and cookies.

1 Like

It is running again. Settings function delete cookies and cache was not working. After deleting cache db it is running again!!