[SOLVED] Basic UI Sitemap default item Rollershutter ERR text

Hi all,

it is most probably a stupid question but I’ve currently no idea where it comes from.
In the sitemap I’ve set the rollershutter as default item:

Default item=EG_Rollo_Schlafzimmer_Rechts

Does anybody know where the “ERR” comes from and how to control or remove it.


What is your Item definition?

Rollershutter EG_Rollo_Kueche_Links "Rollo Küche links" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQ0269947:1#LEVEL"}

Try using the correct item name.


Should have the same item name.

Sorry my mistake, I gave the wrong definition. I believe the names are fine.

 Frame label="Rolläden" {
    Default item=EG_Rollo_Kueche_Links
    Default item=EG_Rollo_Kueche_Rechts
    Default item=EG_Rollo_Schlafzimmer_Links
    Default item=EG_Rollo_Schlafzimmer_Rechts
    Default item=EG_Rollo_WZ_Links
    Default item=EG_Rollo_WZ_Rechts
    Default item=EG_Rollo_AZ

Rollershutter EG_Rollo_Kueche_Links "Rollo Küche links" {channel="homematic:HG-HM-LC-Bl1PBUFM:1c2190fb:OEQ:1#LEVEL"} 
Rollershutter EG_Rollo_Kueche_Rechts "Rollo Küche rechts" {channel="homematic:HG-HM-LBl1PBU-FM:1c2190fb:OEQ:1#LEVEL"} 
Rollershutter EG_Rollo_Schlafzimmer_Links "Rollo Schlafzimmer links" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQ:1#LEVEL"} 
Rollershutter EG_Rollo_Schlafzimmer_Rechts "Rollo Schlafzimmer rechts" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQ:1#LEVEL"} 
Rollershutter EG_Rollo_WZ_Links "Rollo Wohnzimmer links" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQ:1#LEVEL"} 
Rollershutter EG_Rollo_WZ_Rechts "Rollo Wohnzimmer rechts" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQ:1#LEVEL"} 
Rollershutter EG_Rollo_AZ "Rollo Arbeitszimmer" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQ:1#LEVEL"}

Have you tried restarting OH?

I just did. Result stays the same :frowning:

When I take a switch item and use it as default in the sitemap no ERR text appears. Seems to be special with Rollershutter items.

See what happens if you change from Default to something like Setpoint.

Not much better. I’ve changed the first to setpoint.

Maybe need to back up and start with what version of OH is being used along with any other info that might help.

1 Like

I see no reason why it should say ERR next to the controls. I agree with H102, what version of OH, how did you install it, what is it running on?

This might be something that needs an issue opened.

I found something in the logs. But I don’t know why it tries a transform operation:

2019-02-15 23:36:22.890 [WARN ] [ui.internal.items.ItemUIRegistryImpl] - Exception while formatting value '0' of item EG_Rollo_Kueche_Links with format '%.2f %unit%': Conversion = 'u'

With limited info all we can do is guess at how to solve the issue.

Guess one is to use these commands and clean the cache.

**sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2

I’m on OH2 Version: 2.4.0 (Build)
RPI 3 with Raspian stretch

I’ve followed your steps and also restarted RPI. Issue still persists.

I’ve found that link, will have a look at it:


1 Like

I searched github for a similar issue but came up empty handed. Have you used this config successfully with a previous OH version?

1 Like

Good find.:+1:

Try all the config options in the topic and hope one of them works. If nothing you may want to open an issue on github.

I found a solution now:

Define the item not with LEVEL but with DIRECTION:

Rollershutter EG_Rollo_AZ "Rollo Arbeitszimmer" {channel="homematic:HG-HM-LC-Bl1PBU-FM:1c2190fb:OEQXXXXXX:1#DIRECTION"}

In the sitemap it can be used as default and will show you the percentage value how far the blind is closed:

Default item=EG_Rollo_AZ

Now it looks nice :slight_smile:

Thanks you both for your ideas and effort!
Best regards

1 Like

Good deal.:+1:

Please click the square box on the post with the solution and edit the title to start with [Solved]. This will help others with a similar issue find a quick solution.


1 Like

DIRECTION does not give you the possibility to change LEVEL via Alexa. I found out that the default formatting of the value is the root cause. So I changed the label to include a formatter for the value:


Rollershutter   FF_Hallway_Warema         "Warema Empore [%.0f %%]" <rollershutter> (FF_Hallway, gWarema)    ["Switchable"]        {channel="homematic:HM-LC-Bl1PBU-FM:3da6a785:LEQ1XXXXX:1#LEVEL"}


Default item=FF_Hallway_Warema label="Empore [%.0f %%]"