[SOLVED] BasicUI no longer working with MQTT

  • Platform information:
    • Hardware: RPi 3
    • OS: openhabian 2.3, Linux 4.14.34-v7+
  • Issue of the topic:
    Recently my BasicUI has stopped working with MQTT in/out; it previously worked fine for about 6 months. I cannot control switches, and data is not being displayed from sensors.
    However MQTT/Mosquitto is definitely working, I can control devices directly and I can also get telemetry data and display it to BasicUI if parsing through Node-Red to Update the Item?

Only thing I can think of is general updates being applied, I’ve been though all of the configs etc and can’t find anything, items etc. haven’t changed, PaperUI shows both the Action and Binding for MQTT being active, and json transformations are still active.

  • Please post configurations (if applicable):
    • Items configuration related to the issue
      example:

Number wemos1_temp "Inside temperature: [%.1f C]"
{ mqtt="<[mosquitto:tele/sonoff_wemos1/SENSOR:state:JSONPATH($.DHT11.Temperature)]"}
  • Sitemap configuration related to the issue
    example
sitemap default label="Default"
{

Frame label="Sonoff Switches"
{
	Text item=wemos1_temp
}
 
}
  • If logs where generated please post these here using code fences:

Binding configuration of type 'mqtt' of item 'wemos1_sensor' could not be parsed correctly

the log entry refers to another Item that you have defined. Can you post this also? (or maybe you created this second one via PaperUI?)

also: add a space at the end of the item config, just before the closing } (this shouldn’t be a problem…)

Number wemos1_temp "Inside temperature: [%.1f C]" { mqtt="<[mosquitto:tele/sonoff_wemos1/SENSOR:state:JSONPATH($.DHT11.Temperature)]" }

If you can’t find the reason look into this issue :

The workaround (remove the action and reinstall it) might help.

Sorry that “sensor” one was a test, I’ve just tested again removing and re-adding “wemos1_temp” from both the items and sitemap, but did not get the same error. But still no resulting data when the telemetry triggers; when I re-activate my Node-Red flow extracting the data from the json from the telemetry and passing it to wemos1_temp it DOES update and display in BasicUI

listening for MQTT topic: tele/sonoff_wemos1/SENSOR

through JSON parser, then extracted via function

var value = msg.payload.DHT11.Temperature
msg.payload = value;
return msg;

ItemUpdate on ItemName “wemos1_temp”

Your item config is correct.
The hint about removing the action and reinstalling it is good. It has created problems before.
Do you really need the action?

Uninstall the action, restart OH
Install it again

Thanks vzorglub and opus, I think I thought opus’s post was part of the page footer! Have uninstalled the Action and Binding via PaperUI, rebooted, re-installed, and it’s back working!
Strange that the solution didn’t come up in any of my searches, I did update/reinstall mosquitto as that was mentioned elsewhere but that didn’t solve the issue.
That said it’s more of a band-aid than a solution, doesn’t really solve what the problem was and still seems to be a recurring issue a year later.

1 Like

Glad it’s sorted . Can you tick the solution post, please. Thanks

Happened to me as well.