[SOLVED] BasicUI shows icon for webview

Hello everybody,

after upgrading to OH 2.4 i see a “not found” icon whithin my sitemap where a webview item is configured.
Screenshot:

Sitemap:

Text item=Temperature_SmokeDetector_Floor_GroundFloor
Text item=Temperature_SmokeDetector_Entrance_Attic
Text item=Temperature_SmokeDetector_Bedroom_Attic
Text item=Temperature_SmokeDetector_Kids_Attic
Text item=Temperature_SmokeDetector_LivingRoom_GroundFloor
Text item=Temperature_SmokeDetector_LivingRoom_FirstFloor
Text item=Temperature_SmokeDetector_Entrance_FirstFloor
Text item=Temperature_SmokeDetector_BedRoom_FirstFloor
Text item=Temperature_GroundFloor_Dining
Webview url="http://openhabianpi:3000/d/ioB0_uWgk/raumtemperatur?edit&orgId=1&kiosk&theme=light&from=now-30d&to=now" height=11

When I look for the properties of this icon, it shows me:
image

Any ideas?
This wasn’t the case with OH 2.3…so something might have been changed or I am using the webview item the wrong way?

2 Likes

Label and icon were added to the webview widget. They were considered as missing.
So adding icon=none for example in your sitemap should probably solve the not found error.

3 Likes

Thanks a lot :slight_smile:

Hi @Lolodomo,

Do you mean add icon=none at “Configure Basic UI”? as I only have iconType, I change the value to none at advance mode and add icon=none as well, but issue still remain? any idea? when first load to page will have broken img icon, reload will invisible.

at browser console still able found 404 warn %E5%9C%96%E7%89%87

I also found that chart come with a line it only will dispear when chart have 3 or more in one page then last chart won’t have a line

I am not sure if this issue is really solved. The fact that now an icon is being shown does not make sense to me. A webview is typically different from a simple data item, it typically includes a larger web element. It should be possible to completely disable the rendering of an icon. For example, when one only links to a URL and not to an item, then no icon should be shown. Is there a way to accomplish this?

Create a transparent icon and display that instead.

For information, here is a link to the change done last Augoust.

Interesting idea. Will try this workaround.

Well, I tried a transparent icon with 64x1 size, yet while this makes the visual icon disappear, the empty line for the icon still persists. Is there any way to also get rid of this empty line?

Can we see?

Sure, here we go.

You can define the height of the webview in the sitemap.

i’m not quite sure if that’s really the solution?
The webview now comes like any other item.

Therefore it reserves a “slot” in the basic UI where usually the items definition comes (like ON/OFF for switches and the item label).

I think that’s the white gap we’re seeing in the picture above, but i can’t tell if that was the same in OH 2.3

Resizing the Webview would just expand it more to the bottom

The height of the webview item refers to the whole thing, not to the one line that I am trying to get rid of. If I would set it to height=1 then I would only see the empty line, and nothing of the embedded web elements.

Ok, it was worth trying…
I think raising an issue on gitHub looks like the way forward

Just found this https://github.com/eclipse/smarthome/issues/6640 while looking around for this behaviour. To me it’s actually a bug that should be fixed since it made the behaviour worse compared to before.

I’m migrating from 2.1 to 2.4 and after the time consuming migration from KNX1 to KNX2, i’am also struggeling with this empty line in webviews.
Any ideas how to solve this?

There is an issue on gitHub about this already.

For anyone struggling with this I have a temporary fix. @trant @Sascha_Billian @isenberg

Include the following in the head of the page you are loading in the webview.

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.0/jquery.min.js"></script>
<script type="text/javascript">
		$(parent.document).find('.mdl-form__row.mdl-form__row--height-auto.mdl-cell.mdl-cell--12-col').prev().css("display", "none");
</script>

I should add while this works for my use case, I’ve not fully tested it and may have not spotted a side effect.

Chris

2 Likes

Would it maybe even work to to produce an additional html document with just these scripts and to include this in addition to any webview one already has? Then the change would only be an additional (yet invisible) webview per hierarchy level in the sitemap that has a webview in it, one would not have to mess with the existing html pages (some of which may not even be under our control). I have not tried this yet since I do not have the time, but this may be an idea … (I’ll try it later)