[Solved] Binding built with new IDE ignored in a 1.8.1 server

I have a strange problem.
I setup the new IDE and build my binding using Maven.
The produced jar is OK in openHAB 2 beta 2.
When I use this jar in a new installed server 1.8.1, it looks like my jar file is simply ignored. I see absolutely no entry in my logs about this binding.

One old compiled version of this binding (previous IDE) is still working in 1.8.1.

The only differences in sources I can identify are:

  • the adding of the tag immediate=“true” in binding.xml
  • few differences in the imported packages in the MANIFEST.MF file
Import-Package: gnu.io,

while previous jar was built with these packages:

Import-Package: gnu.io,

Can it explain that my jar is ignored in 1.8.1 ?

Is there a way in the OSGi console to see if a binding is loaded ?

What could be the reason for my jar file to be not loaded or not started ?

Another difference is that with the new IDE I installed Java 1.8 SDK while with the previous IDE I used Java 1.7 SDK.

Suppressing the versions solved my problem.
The version were automatically added using IDE (Eclipse).