[SOLVED] Blank login page - Only page title with icon displayed


My OH 3.1.0 suddenly stopped working.


I only have the login page title, but nothing else. I have restarted the box several times, cleared the cache without luck.

I have noticed some error in the console.

The app on iOS can connect, but the switch buttons do not work as expected.

I tried with DuckDuckGo on iOS and also a blank page. :neutral_face:

Any idea on how to fix this issue?

Not sure what the issue might be, but just to check the most obvious first:

  • What version of openhab are you running?
  • Have you tried clearing the browser cache?
  • Are there any errors in openhab.log?
  • Have you restarted openhab after clearing the (openhab) cache?
  • Do you use a reverse proxy? (I guess not, since you connect to port 8080, but still)

The first screenshot states ‘Unable to parse IP . Please debug’ Hence, try to login on your OpenHAB server and ensure it is getting a proper IP Address.

Thanks for your answer. :slight_smile:

So what I noticed a bit after my post was that the events were still flowing in the log file. The app was working also, but the web GUI was still not working properly. I checked several tabs from the Developer Tools (Firefox), and when I was on the AdBlock part, suddenly the page got displayed. AdBlock Plus and any other plugins are disabled for the site. So this is really something weird… No idea what happened.

This message was there from day one of the installation and has been working correctly. See my previous post, things cleared alone…

Thanks for your reply. :slight_smile: