[SOLVED] Bticino Gateway Problem

Hi there,

I have been learning very much of this Forum and got most of my Knowledge from here but at this Point i have to ask the community :slight_smile: My OH Server is running on a Raspberry PI any eyerything worked out perfect. 2 Days ago i sudddenly got an error message in my OH Configuration and it doesnt work with Alexa anymore. I didn´t Change anythin in OH, on the PI or in MYhome Suit. I also didnt Change anything in the Alexa App. The F454 Gateway is still detected when starting OH on the pi but it is not detected in OH when using the openhab web net binding to search for the bridge.

That are my Errors which i get. I hope someone can help here without setting up everything from the Scratch…

Thanks for Help.

Could you copy and paste the log in here instead of a screen shot, please?

Insert the log in code fences:

Sorry for the screenshot. As i sayed it was my first post… I hope ist better now. At least it Looks better for me in the preview :thinking: If you need something else let me know.

2019-01-05 11:02:59.928 [ERROR] [org.openwebnet.AbstractOpenGateway  ] - ERROR IN Java $MODULE$: connection cannot be established
==> /var/log/openhab2/events.log <==
2019-01-05 11:02:59.930 [hingStatusInfoChangedEvent] - 'openwebnet:bus_gateway:c609c344' changed from UNINITIALIZED to INITIALIZING
2019-01-05 11:02:59.945 [hingStatusInfoChangedEvent] - 'openwebnet:bus_gateway:c609c344' changed from INITIALIZING to UNKNOWN
==> /var/log/openhab2/openhab.log <==
2019-01-05 11:03:19.935 [INFO ] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler status still UNKNOWN. Setting device=openwebnet:bus_gateway:c609c344 to OFFLINE
==> /var/log/openhab2/events.log <==
2019-01-05 11:03:19.946 [hingStatusInfoChangedEvent] - 'openwebnet:bus_gateway:c609c344' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR)
2019-01-05 11:10:33.655 [ome.event.ItemCommandEvent] - Item 'Licht_Arbeitszimmer' received command ON
==> /var/log/openhab2/openhab.log <==
2019-01-05 11:10:33.665 [ERROR] [ding.bticino.internal.BticinoBinding] - Item [Licht_Arbeitszimmer] uses Bticino interface with ID [webserver] but this gateway doesn't exist : check items.cfg and openhab.cfg!

which version of the openwebnet binding are you using ?
are you using bothe the openwebnet binding the and biticino 1.x binding?


Hey Massi,
I am using the 2.4.0 Version of the binding and the 1.12.0 of the bticino binding. This worked well since 2 days ago.

LG Stephan

I am not sure but I think I saw another thread about the same thing yesterday or this morning
I can’t find it now. But according to the error log, it looks like that the json structure has changed slightly

Go to PaperUI > Configuration > Bindings
There you can find the OpenWebNet binding beta version you have installed.
It is also very strange you use both bindings (Bticino 1.x and OpenWebNet)
Why would you do that?

Ok i am using OpenWebNet Binding (beta7). I also have bticino binding 1.12.0 installed under Addons but the binding doesnt appear under Configuration/Bindings so i think i only use the openwebnet binding. Dont know why i installed the bticino binding.


Then you should install OpenWebNet beta9-1 (see the README for instructions on how to upgrade)
(older bindings work for a limited time)

And I also suggest you remove the BTicino binding form addons if you do not use it .


1 Like

I managed to remove the old binding and uninstalled the bticino one. Installed the new 9-1 Version and it works. I onlly have to rename the new discovered Things but thats far less work than Setting up everything new. I still dont understand what happened to my Installation but iam happy that it works again :grinning:

Great Thanks to Massi…helped me a lot. :hugs: