[SOLVED] Cannot access OpenHAB after update to 2.4

I’ running OpenHAB on a Raspi, and after the update with apt-get, I cannot reach it any longer.

service openhab2 status 

shows the server running, and an attempt to connect to http://:8080 returns a Jetty error message (“HTTP ERROR 404//Problem accessing /start/index. Reason://Not Found”). This shows that the server is basically running.
But when I try to connect to port 9001, the connection is refused.
Next, the log files will be created, but they remain empty (length 0 bytes).

I tried the stop, start, restart OpenHAB, and, of course, tried also to reboot the machine, more than once.

Any ideas?

Have you tried a reboot since upgrading?

sudo systemctl stop openhab2

sudo reboot

Jepp, I also tried to stop, start, restart OpenHAB, and I also tried to reboot the machine.

I updated my question AFTER the comment from @H102, but I tried these basic thing BEFORE I issued my post. Nevertheless, as I did not mention it, @H102’s question was perfectly valid …

With the 2.4 upgrade a clean cache is built in but it may be worth trying it via openhab-cli.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2

1 Like

Stopping the OpenHAB server

sudo service openhab2 stop

cleaning up the cache

sudo openhab-cli clean-cache

and then restarting the server again

sudo service openhab2 start

finally did the job.

sudo service <_service_> <_command_>

is equivalent to

sudo systemctl <_command_> <_service_>

as suggested by @H102 – at least on my Raspi …